Gcloud setting the proxy.

Heyas,

I have installed the Google Cloud SDK on my system and when I type in the command gcloud I get the following response, see screenshot. I have changed the environment variables as the stackoverflow forum entry advised: http://stackoverflow.com/questions/23433998/gcloud-is-not-recognized-as-an-internal-or-external-command

Then I realized perhaps it was the proxy I was behind.  Running the following python command see screenshot, I got a proxy auth required message. How does one set the proxy details in Gcloud?

Thank you.
Gcloud-command-fail.PNG
Windows-Environment-Variables.PNG
Proxy-Auth.PNG
ZackGeneral IT Goto GuyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Koen Van WielinkBusiness Intelligence SpecialistCommented:
I'm assuming you're running the latest version of the SDK, but just in case, I discovered this issue report from Google:

https://code.google.com/p/google-cloud-sdk/issues/detail?id=50

Can you try to run the update command and see if the issue goes away? From what I gather under normal circumstances the SDK would just use your system proxy settings.
ZackGeneral IT Goto GuyAuthor Commented:
Hi Koen,

Yes using the latest SDK ran the update command no change.

Thank you.
Koen Van WielinkBusiness Intelligence SpecialistCommented:
From everything I can gather, it should simply look at your Windows proxy settings. My best guess with the info given is that either your proxy settings in Windows are not complete (I've had this in the past with our corporate proxy. It worked with just the IP address and ports filled because the authentication was taken from my Windows login, but every now and then a site or application would still prompt for authentication), or that the proxy server has blocked your download.
Double check your proxy settings in IE, and any other browsers you use, and if that doesn't solve it, try using another connection (I used to bypass our firewall by connecting my laptop to my mobile phone hotspot, don't tell anyone :p).

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ZackGeneral IT Goto GuyAuthor Commented:
Unfortunately I had to use my mobile phone as my network admin refused me access to the Cisco router my last point of investigation. Thanks for the help anyway.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cloud Computing

From novice to tech pro — start learning today.