adding host to vCenter times out


I had to move a local vSphere host to a colo facility, while leaving vCenter here at the office.  I mapped an external IP address on port 443 to it and can see it with the vSphere client in stand-alone mode.  Trying to add it to vCenter doesn't work; it seems to see it but then times out when trying to complete the importing.  I'm assuming I need to open more ports for vCenter's use, or is this something else I'm missing?

vSphere 5.5.0 and vCenter 5.5.0 build 2001466


Ben ConnerCTO, SAS developerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
What is the speed of the link, and what is the latency of the link ?

you may want to check the logs, for the reason of the timeout

Here is a list of ports required

the first link shows the ports you need to ensure are open between vCenter Server site and ESXi host site.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ben ConnerCTO, SAS developerAuthor Commented:
The new facility is outstanding.  The old one (my office) now sucks.  Ergo the move..

Didn't think that would be the issue since I can use the client directly to pull them up.  Will check out the links.  Thanks!

Ben ConnerCTO, SAS developerAuthor Commented:
Good lord.  The 2nd link goes on forever on ports.  It would be easier to try to set up a VPN between the two locations.  Will try to open the ports in the 1st link and see if that works; otherwise will pursue a VPN solution.


10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
is there a reason, vCenter Server is not on the same site as the hosts?
Ben ConnerCTO, SAS developerAuthor Commented:
Hi Andrew,

I had placed vCenter on a physical box so I could do maintenance more easily on the hosts.  And that box also was the backup target for my other physical workstations.  

I also came to the same question--why not put it on one of the hosts?  So I ran a copy of the vCenter converter standalone (vsn 5.5.1 build 1682692) on it into a VMWare workstation instance I have to make sure it works.  It had issues--the vCenter server would not come up.  Thought I might have messed something up so I removed and reinstalled vCenter.  That went great...until I tried to log in.  No combination I could think of worked, much less what I gave it as the original password.  Sigh.

So I blew that VM off and started over.  Re-converted the physical box, but this time un-joined the domain and rejoined it with a different machine name.  And chose an older machine architecture (vsn 9).  That just came up a few seconds ago.  

Trying to log in to that I get the same thing: vSphere Client could not connect to "vcenter" An unknown connection error occurred. (The request failed because of a connection failure. ( Unable to connect to the remote server).  

Finally dawned on me this may not have been a vCenter issue--and sure enough it wasn't.  It was a dns issue.  The ptr record was not updated, pointing to an IP that isn't here now.  It's in the colo facility.  

Updating the ptr record in the AD server got me to the right machine, and it logged in just fine.  Now I can shut this down, take it over there, and load the VM onto that network.

Thanks, Andrew.  You've been quite helpful, as always!

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
No problems!
Ben ConnerCTO, SAS developerAuthor Commented:
Dang.  Well, I thought this would be easy.  After verifying the Workstation version of vCenter came up fine, I uploaded it to the host, gave it a static IP address, had it join the domain, verified the IP addresses were correct, and neither vCenter Server nor the vCenter Management Webservices will start.  

The Application event log isn't terribly helpful.  I see the following error entries in it for the vCenter Server:
The description for Even ID 1000 from source VMware VirtualCenter Server cnanot be found.  Either the component that raises this event is not installed on your local compute or the installation is corrupted.  You can install or repair the component on the local computer.  If the event originated on another computer, the display information had to be saved with the event.  The following information was included with the event: Error getting configuration info from the database   the message resource is present but the message is not found in the string/message table.

and earlier in the System event log I found:
The VMware VirtualCenter Server service terminated with service-specific error.  The system cannot find the file specified.


It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.