Getting Permission denied (publickey) tyring to connect using ssh

HI,
I am using the following command to connect to a host_ip :
ssh username@host_ip
My username n public key has been added to the server.
The host_ip also appears in known_hosts file .

Files under my .ssh directory :
github_rsa      github_rsa.pub      id_rsa            id_rsa.pub      known_hosts

I tried the ssh command with -v option following was the output :
ssh -v username@host_ip
OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: /etc/ssh_config line 102: Applying options for *
debug1: Connecting to host_ip [host_ip] port 22.
debug1: Connection established.
debug1: identity file /Users/robinsuri/.ssh/id_rsa type 1
debug1: identity file /Users/robinsuri/.ssh/id_rsa-cert type -1
debug1: identity file /Users/robinsuri/.ssh/id_dsa type -1
debug1: identity file /Users/robinsuri/.ssh/id_dsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
debug1: Remote protocol version 2.0, remote software version libssh-0.7.0
debug1: no match: libssh-0.7.0
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-sha1 none
debug1: kex: client->server aes128-ctr hmac-sha1 none
debug1: sending SSH2_MSG_KEXDH_INIT
debug1: expecting SSH2_MSG_KEXDH_REPLY
debug1: Server host key: RSA 16:27:ac:a5:76:28:2d:36:63:1b:56:4d:eb:df:a6:48
debug1: Host 'host_ip' is known and matches the RSA host key.
debug1: Found key in /Users/robinsuri/.ssh/known_hosts:2
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /Users/robinsuri/.ssh/id_rsa
debug1: Authentications that can continue: publickey
debug1: Trying private key: /Users/robinsuri/.ssh/id_dsa
debug1: No more authentication methods to try.
Permission denied (publickey).

Open in new window


I also tried adding the line ChallengeResponseAuthentication yes
  in sshd_config file
but still getting the same error. I saw this in one of the solution so thought probably this will make it work. but it didnt.

what could be wrong?

Please help
Thanks
Rohit BajajAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rohit BajajAuthor Commented:
One thing i notice is in the following lines :
Offering RSA public key: /Users/robinsuri/.ssh/id_rsa
debug1: Authentications that can continue: publickey
debug1: Trying private key: /Users/robinsuri/.ssh/id_dsa

Open in new window


I dont have any file named id_dsa
savoneCommented:
Some things to check:

1) Did you copy over the public key to the remote server?

2) Did you set the correct permissions on .ssh directory?

chmod -R 700 ~/.ssh

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rohit BajajAuthor Commented:
Hi,
There was something wrong with setup on server side. I got connected now
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSH / Telnet Software

From novice to tech pro — start learning today.