Help with RD licensing errors - Windows Server 2012

I have done everything I can find to do - I have installed RDS services, I have purchased licenses, I have defined my server to be the RD Session Host server, the RD Licensing Server, and I have installed the licenses.  I had the licenses defined as per user and installed the purchased licenses as per user, but it didn't work (licensing error below).  I have rebooted.  I then changed the licensing mode from 'per user' to 'per device' as there is an unlimited license for that in RD licensing.  This doesn't work either - same error.  So I took things a step further as per some online advice - I also set up my server as the RD Connection broker server and the RD Gateway server.  Still get the error...also I can't find a way to directly access 'RD Session Host' utility...that seems to be an issue for lots of people though it is an aside.

The licensing error says 'The licensing mode for the Remote Desktop Session host server is not configured' and the grace period is expired.  I cannot connect to this server via Remote Desktop Connection.

I have attached a screenshot of the RD licensing diagnoser.  Thanks, Dawn
Screenshot--1-.png
Dawn SpieglDirector of TechnologyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
These are 2012 RDS licenses? Your image doesn't show the licensing error.

I then changed the licensing mode from 'per user' to 'per device' as there is an unlimited license for that in RD licensing. TRIAL ONLY not real licenses or I'd get one and save a lot of money.
David Johnson, CD, MVPOwnerCommented:
Step 1Step 2Step 3Step 4step 5step 6step 7
Dawn SpieglDirector of TechnologyAuthor Commented:
Was this what you were asking for?  As you see, yes - the licenses are installed.  And, all of the RD services are already installed as well....
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

DrDave242Senior Support EngineerCommented:
Is this server a workgroup member, domain member, or domain controller?
Dawn SpieglDirector of TechnologyAuthor Commented:
Domain member - 2012 Server; Domain controller is 2008 R2 and it has properly installed and running RDS
DrDave242Senior Support EngineerCommented:
I've seen this happen multiple times - even though the license server and licensing mode are properly configured, and the necessary CALs are installed on the license server, the session host simply refuses to believe it.

The fix isn't always the same thing: sometimes simply restarting the Remote Desktop service or rebooting the server is sufficient to fix it, but sometimes it's necessary to configure the license settings another way. Check this link and scroll down a bit, where you'll find sections called Configuring license server manually and Configuring license server using Group Policy. Try one of those methods, and if it doesn't work, try the other one.

Let me know how it goes.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dawn SpieglDirector of TechnologyAuthor Commented:
Well...I did uninstall RDS altogether this afternoon - I had been struggling with it so long, I decided to just start over.  I followed instructions above to re-install - had to choose 'Remote Desktop Services installation' to get the 'Session-based desktop deployment' option though.  From there, I chose 'Quick Start..' which sets the same server for all roles.  It started the install, rebooted and then I get errors when the system comes back up to finish.   So frustrated -  I have attached the screen.  

I'd be happy to try your suggestion...but I can't even get it to install now.  uggggghhh...
David Johnson, CD, MVPOwnerCommented:
no screen shot
Dawn SpieglDirector of TechnologyAuthor Commented:
Screenshot--5-.png
DrDave242Senior Support EngineerCommented:
Can you verify that the necessary role services are all installed? For a Quick Start deployment, that'll be the Session Host, Connection Broker, and Web Access services. Your screenshot appears to show that they all installed successfully, but it won't hurt to be sure.

If they're all there, try to create a session collection manually, since that seems to be where things went wrong. If this doesn't work, post any errors you receive here. If it does work, try to add the Licensing role service and specify the license settings as you normally would.
Dawn SpieglDirector of TechnologyAuthor Commented:
My screen shot shows that session collection install failed and remoteapp programs failed - does that not matter?  I just assumed...it was late :).  Anyway, I checked and yes the RDS are installed.  I activated and added the licenses - which actually showed up by themselves.  Problem still the same as my first screenshot.

Then I followed the instructions to 'Configure Manually' - tried first way, error changed in licensing diagnoser - now just says the session host is not configured as 'per user' or 'per device'.  So I did the second way.  I did 'gpudate /force' on the domain controller, and checked that the group policy was applying to the RDS server in question, and logged off and back on after 20 minutes.  Still the same error.  I may reboot later to see if I can effect a change.  

Any thoughts further appreciated!
DrDave242Senior Support EngineerCommented:
I did 'gpudate /force' on the domain controller, and checked that the group policy was applying to the RDS server in question, and logged off and back on after 20 minutes.
Gpupdate /force should actually be run on the RD server rather than the domain controller, and since it's a computer policy rather than a user policy, logging off and back on won't refresh it. It may have refreshed on its own by now, though. You can run gpresult /h gpresult.htm on the RD server to generate a report of all applied Group Policies and their settings. If you don't mind, open that file and drill down to Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Licensing\ just to make sure the correct settings are applied. Feel free to post a screenshot of that section of the report if you'd like.
Dawn SpieglDirector of TechnologyAuthor Commented:
Well the problem is changing for sure - did as you suggested.  Just to clarify - in the screen shot showing the gpresult, I have defined 2 licensing servers - the domain controller and the domain member we have been working on.  

As you can see in the second screenshot, the licensing diagnoser is now showing just an error about the domain CONTROLLER, not the domain member we are working on.  Still, licensing does not work - I am given a message when I try to RDC that 'there is no licensing server available' and I get the balloon on the domain member telling me RDS Session host is not configured.  

There are no known issues with the RDS on the domain controller...
Screenshot--6-.png
Screenshot--7-.png
DrDave242Senior Support EngineerCommented:
The warning about the DC is expected; since it's running 2008 R2, it can't serve as a license server for a 2012 or 2012 R2 session host server because those CALs can't be installed on it - they're not forward-compatible.

The diagnoser even shows that there are 20 licenses available now. I'm kinda baffled why you're still getting the "No licensing server available" errors. Let me see if I can dig up anything.
DrDave242Senior Support EngineerCommented:
Try backing up and deleting the GracePeriod registry key as shown here. I've seen mixed results with this myself. I've never seen it cause a problem, but it doesn't always work.

After deleting the key, reboot the session host server.
Dawn SpieglDirector of TechnologyAuthor Commented:
Will do - have to wait till evening to reboot it, but will check back in with you when I get back in next Tuesday - thanks!
Dawn SpieglDirector of TechnologyAuthor Commented:
Well what do you know - I was able to get a reboot in so I did the key deletion.  And voila!  I can use RDC to get to that server now and no evil balloon message.  I wonder though - does this mean that I am in another grace period that when it expires will put me right back where I am?
DrDave242Senior Support EngineerCommented:
What does the licensing diagnoser show now?
Dawn SpieglDirector of TechnologyAuthor Commented:
Same - screenshot attached
Screenshot--4-.png
DrDave242Senior Support EngineerCommented:
Have a few users connect via RDP, then open the RD Licensing Manager, right-click the server, and select Create Report > CAL Usage. The report will appear in the console, but it appears that you have to right-click it and save it to a file before you can actually see the data in it.

If the report shows that user CALs are being issued, things are working correctly.
Dawn SpieglDirector of TechnologyAuthor Commented:
Thank you Dr Dave - for your excellent help and for sticking it thru to the end!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.