Installing rpm without root access

HI,
I want to install an rpm on my linux machine but i dont have root access. Also i need to unpack it only for my user.
How do i do it ?
I tried rpm2cpio codeSnippet-1.0-null.x86_64.rpm | cpio -idv But it didnt work.
I was expecting file snippet.war to be placed inside /home/robinsu/tools/jetty/webapps once it gets unpacked.
But it didnt happend. please find an image for reference of whats inside the rpm.
Thanks

rpm.png
Rohit BajajAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

serialbandCommented:
Have you tried rpm2tgz?  http://pkgs.org/download/rpm2tgz

rpm2tgz package.rpm
tar zxfv package.tgz

That looks like a Mac screenshot.  What are you missing?  I see it in the folder.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.