IIS Website displaying server error in '/' Application

I have a website that wont display correctly when I have the storageRoot0 value in application settings set to a unc path on another server
if I change the unc path to something local like c:\test it displays ok
I have attached screenshots
what could be causing this?
I need to have the storageroot0 pointing to a server in my lan
Capture.JPG
LVL 1
dougdogAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerCommented:
What are you doing exactly? Are you using some other custom made package?
Most probably, it's just not designed to work from a remote server. Ask the developer of that custom package you're using.
0
Kyle AbrahamsSenior .Net DeveloperCommented:
I would agree with Kim but try using 2 slashes instead of one.

eg:  \\\\<ip>\\path

The other thing you can try is mapping that drive to say X: and then use that as a local drive.
0
Dave BaldwinFixer of ProblemsCommented:
The IIS user does not have permission to access other servers.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

dougdogAuthor Commented:
What permission is needed
0
Dave BaldwinFixer of ProblemsCommented:
Try the 'mapped drive' approach.  I don't think you are able to give the IIS user permission to access other servers.
0
dougdogAuthor Commented:
Mapped drive didn't work
0
systechadminConsultantCommented:
please assign the Network services and IIS_Users permission, IIS_WPG group
0
dougdogAuthor Commented:
Are these permissions assigned on the it's server
Or the server that is hosting the file share
0
Dave BaldwinFixer of ProblemsCommented:
It's the permissions of the IIS User.  It is a special user for the web server and it is intentionally limited by design.
0
dougdogAuthor Commented:
Yes but what server
I have the fronet end server with its accessing a file share on another server that does not have its
Where do I configure permission
0
Dave BaldwinFixer of ProblemsCommented:
In all the previous questions about accessing a remote server from IIS, the answer has always been that you can't.  The problem has always been that the IIS user does not have and can not be given permission to access other machines.
0
dougdogAuthor Commented:
I have 2 iis servers that are on a subnet
if I try the storageroot0 location as local on one of the iis servers it works and even if I have the folder on the second iis server as a unc path it works
but if I have the file location on another server that does not have iis installed and on a different subnet I get the error
0
KimputerCommented:
If that's the case, it's still an authentication problem, and if different subnet, check also if your network settings are correct (source should be able to ping destination and vice versa).
0
dougdogAuthor Commented:
I can ping and access the file via cifs or explorer
its just browsing the website from the iis server fails
0
KimputerCommented:
Accessing the files is a good step (networking in correct order).
However, you're accessing it as the user you're logged in with.
The app will be accessing the files with the IIS_Users account, which the OTHER side will know nothing about. Just create that account with the correct password on the DESTINATION server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kyle AbrahamsSenior .Net DeveloperCommented:
that or map the drive as a persistent drive.
0
dougdogAuthor Commented:
just create the same local account?
or maybe install  the iis role on the file server
that would install the iis accounts
0
Kyle AbrahamsSenior .Net DeveloperCommented:
You're better off switching to a domain account for your application pool, then granting permissions on the file server for that account.

Note you should add the same domain account to the IIS_Users local group on the web server.  The IIS user is a local account, so even if you were to install IIS on the file server, it wouldn't grant permissions.
0
dougdogAuthor Commented:
the 2 iis servers will be out on the dmz
the file share will be inside the lan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.