unable to rdp to server

I have a Windows 2003 server and cannot use remote desktop to connect to it. Several days ago the server displayed a message that it was low on resources. Is there anything I can do remotely (aside from rebooting) to enable resources for remote desktop?
exhuserAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

upalakshithaCommented:
Hello,
Some times it may be already disconnected sessions are stuck or high resource usage.try this to find & logoff disconected or stuck sessions.
First, check the session number with qwinsta:

QWINSTA /server:computername

Write down the session ID.

Then use the logoff command:

LOGOFF sessionID /server:computername.

See it helps.
Thanks
exhuserAuthor Commented:
No. It did not help.
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
Windows 2000 and 2003 indeed have some issues with resource leaking. This leads to a situation only reboot can help.

But before playing the "reboot does good" game, you should check if any process uses unreasonable amount of memory. Also extend the Task Manager to display GDI and handles to look for processes going in thousands of those. If any resource is extremely high for a process you can restart, you should do.
Instead of Task Manager you can use SysInternals free Process Explorer to reveal more about everything process related.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

exhuserAuthor Commented:
I have no rdp or direct terminal access to the server. Is there anything I can run remotely?
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
You can retrieve performance counters remotely - maybe. Usually the server collapses after some time, asked until then less and less of means remain to get any info.
You can try if Sysinternals' psExec still works to start a process remotely. And/or use tasklist and  taskkill remotely in psExec or locally. Both ways might show processes you can kill.
magodeoz2Sys AdminCommented:
Hello exhuser !

Do you get an error message when trying to access to the server by mstsc.exe ?
datadrewCommented:
The other option is to login to a machine on the network with admin creds.
Start, run
type: shutdown -i
Enter the name of the server and choose to restart it.  It may take some time, but it should reboot.
exhuserAuthor Commented:
No error with mstsc.exe. The connection terminates right after I enter the password.
There was one active RDP, which worked, but not I was "smart" enough to logoff rather than disconnect...
exhuserAuthor Commented:
Tried remote shutdown (shutdown -i). The server accepted the command but never rebooted.

Any idea what to do next?
datadrewCommented:
You are going to have to hard boot it.

You did try the mstsc /console, correct?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
exhuserAuthor Commented:
I've tried mstsc and then, when the prompt came, entered the login credentials. The session terminated shortly. Is there a special format?
datadrewCommented:
Yes, if you use mstsc /console
It should create a console session on the machine.  If that doesn't work, hard boot it.
Just to confirm, when you used shutdown -i
YOu entered the offending server's FQDN in the box, chose restart, put a reason in, unchecked the wait 30 seconds box, and the OK, correct?
magodeoz2Sys AdminCommented:
mstsc /v:hostname /console
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.