Disable auto-login for Outlook.com

At the top of the MSN homepage, there's an Outlook.com button. When I click on that, it brings me to the outlook.live.com web interface for Outlook and automatically signs me in. Even if I sign out of Outlook, the next time I start IE and click the Outlook.com button, I get automatically logged in to Outlook.com.

It logs in without even prompting me for a username and password. So it's not that it pops up a username and password box that is autofilled. There's no password box at all. It just logs in.

How can I turn off this auto-login? I don't want everyone who uses my computer to be able to read my email.

Thanks in advance.
jrmcanada2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Luis MouraCommented:
Check the ie options about, autofill.
And clear all data and passwords from ie.
0
wnrossCommented:
Hi jrmcanada2, this is an easy to solve problem with a tricky cause.

Logging into any of the Microsoft sites causes your browser to store a cookie representing your account. These cookies are set for all of the different domains (sites) that Microsoft controls (live.com, outlook.com, office.com etc...).

Logging out requires that a cookie be removed from your browser for each of the different sites. Usually this process is automatic but since we are relying on the interent sometimes a credential cookie fails to be deleted. At that point youi no longer have an easy way to log out.

Thats the why, what to do is simple: Delete all your browser cookies:

Internet Explorer

To delete cookies in the desktop.

1.

Tap or click the Internet Explorer icon on the taskbar.

2.

Tap or click the Tools button

3.

point to Safety, and then tap or click Delete browsing history

4.

Select the Cookies and website data check box

5.

then tap or click Delete.

In Chrome:

To clear existing cookies:

1.

Go to 'Tools Menu'

2.

Click on 'Options'

3.

Click on 'Under the Hood'

4.

Under 'Privacy' section select "Show Cookies'
A new window should open called 'Cookies' In here you can see all the cookies within your Google Chrome Browser.

5.

Click on "Remove All" to remove all traces of cookies.

In FireFox

1.

Click the menu button

2.

choose History, and then Clear Recent History....

3.

set Time range to clear to Everything.

4.

Click on the arrow next to Details to expand the list of history items.

5.

Select Cookies and make sure that other items you want to keep are not selected.
0
jrmcanada2Author Commented:
Clearing the cache, cookies, etc. didn't work. But I found the solution: log in to your Microsoft account, go to security settings, and clear all approved devices.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jrmcanada2Author Commented:
Because it works
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.