Corrupt Active Directory

I am in a small environment running W2012R2 Server with Active Directory running on a Hyper-V VM.  I rebooted my host this morning and failed to shut down the vms first (I Know now that this is not good practice).  I have gotten away with this before, not realizing the potential for problems.  The server would not boot until I went into DSRM.

My first thought was that everything should continue running since I had a 2nd DC running...until I realized that I had dismantled this 2nd server recently forgetting that it was running the directory.  So, I started trying to repair the directory and am getting errors on everything I try.

I tried ntdsutil semantic database analysis and it ends with "Could not initialize the Jet engin: Jet Error -1022. Failed to open DIT for AD DS/LDS instance NTDS. Error -2147418113

I also tried esentutl recovery and it ended with "Operation terminated with error -1022 (JET_errDiskIO, Disk IO error) after 93.78 seconds."

I then tried esentutl integrity and it tells me I need to run recovery option and ends with "Operation terminated with error -550 (JET_errDatabaseDirtyShutdown, Database was not shutdown cleanly.  Recovery must first be run to properly complete database operations for the previous shutdown.) after 3.875 seconds."

I really don't want to have to start from scratch.  I'm hoping someone out there has an idea on what I might be able to do to repair/recover this directory.
Paul CahoonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott CSenior Systems EnginerCommented:
Do you have a backup of AD to restore from?

If you don't, your choices are pretty much down to calling Microsoft and opening an ticket, or starting over from scratch.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mustafa L. McLinnSystems Engineer/Systems AdministratorCommented:
It sometimes occurs that you simply have to run a repair on the drive... like scandisk.
0
Paul CahoonAuthor Commented:
I am running chkdsk now and hoping that this solves my problem.  Will report back when I know more. Thanks.
0
Paul CahoonAuthor Commented:
ended up starting over from scratch... moral of the story-backup, backup, backup.
0
Pankaj SinghTechnical ManagerCommented:
First need to chk with the disks use scandsk cmd to check all abnormalities, do you have any AD backup? if yes then perform restoration on other DC, or if you are able to boot it up in DSRM mode try dcdiag and try to figure out the main problem from report.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.