Exchange 2013 Shell no longer working

Hi,
I had a problem with certificates in exchange 2013 not showing the correct name. Since changing the virtual directories internal URL and creating a new certificate I have been unable to access the Exchange Shell.

I get the following error. Can anyone help?

VERBOSE: Connecting to abmail.domain.local.
New-PSSession : [abmail.domain.local] Connecting to remote server abmail.domain.local failed with the
following error message : [ClientAccessServer=ABMAIL,BackEndServer=abmail.domain.local,RequestId=5e56dbeb-549c-4058
-915e-fe318d19e773,TimeStamp=10/10/2015 15:41:13]  For more information, see the about_Remote_Troubleshooting Help
topic.
At line:1 char:1
+ New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
   gTransportException
    + FullyQualifiedErrorId : -2144108477,PSSessionOpenFailed
EICTAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amit KumarCommented:
run your command prompt as administrator then run below command:

IISreset

let it complete process and then check.

or you can try reboot your server as well as
EICTAuthor Commented:
Hi fixed this by going to IIS Exchange Backend setting. In the binding settings I was able to reassociation the original certificate with the Virtual Directory.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
EICTAuthor Commented:
Thanks Amit, your comments help.
As an aside Outlook fails to connect to exchange because it has servername as the issuer not servername.domain.local  and therefore comes up as untrusted. Any idea how I can fix this without having to go to every computer and add the certificate to the trusted root certificates.
Amit KumarCommented:
When you open OWA which certificate it shows?

also run below command on your all CAS servers to check which certificate is assigned to IIS

get-exchangecertificate
EICTAuthor Commented:
I fixed this myself, but the reference to IIS helped point me in the right direction.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.