Problem running command from C drive using CMD

Good evening,

We are installing some libraries on our server. I am not sure if this is a permissions problem. I am running this from the CMD as Administrator.

We go to:   cd C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\bin

To run the following command:

ildasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.dll /outM:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.il

I am running the command from drive C, the files are on drive M and it is giving me an error saying it cannot access the files.  
If the files were on C it would be fine, but I am running my websites off M. So that is were the files are, the command works fine (We tested various times in different computers, but all use C for the web).

I am trying to figure out how to access the files on M running this command from a C location.

Is this permissions or do you have any advice on how we should run the command?

(View attached screenshot)
error.PNG
LVL 1
AleksAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bill PrewCommented:
I think you have a typo with the /out option, I think it needs an "=" after it, as in:

ildasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.dll /out=M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.il

Open in new window

~bp
0
AleksAuthor Commented:
Thanks, that fixed that one. The last two instructions may have an error as well.  Your input will be greatly appreciated:

regasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.dll /codebase/tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.tlb

AND


regasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QuikFormsEngine.dll /codebase/tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QuikFormsEngine.tlb
error2.PNG
0
AleksAuthor Commented:
I also tried:

regasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.dll/codebase/tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.tlb

but got:  The given path is not supported.
1
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Bill PrewCommented:
You need a space after the /codebase option, like:

regasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.dll /codebase /tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.tlb
regasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QuikFormsEngine.dll /codebase /tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QuikFormsEngine.tlb

Open in new window

~bp
1
AleksAuthor Commented:
Ok .. I am running everything again from scratch .. Ill update you in 5 min.
0
AleksAuthor Commented:
Almost there. I ran all my commands, but those last two you provided me with are giving an error.
Attached are the two errors I get when I run the commands.

First one is: Strong name validation failed.

Once I get this two commands to run am in the clear  :)
error.PNG
0
David Johnson, CD, MVPOwnerCommented:
regasm C:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QuikFormsEngine.dll /codebase /tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QuikFormsEngine.tlb

Open in new window

0
AleksAuthor Commented:
David: The files are on M, not C.  If I enter "C" It says the .dll cannot be found.

This are the two commands that are giving me that error:

regasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.dll /codebase /tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.tlb

regasm C:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QuikFormsEngine.dll /codebase /tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QuikFormsEngine.tlb
0
Bill PrewCommented:
I think the second command may have worked, just with a warning.  The first can't find your QFEBridgeTest module, but I'm not sure why that is.

~bp
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AleksAuthor Commented:
the path is correct though. I made sure. I want to concentrate on the first one first.
I located the file, it is at:

M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.dll

This is the command I am running for it:

regasm M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.dll /codebase /tlb:M:\Web\QFEBridgeTest\QFEBridgeTest\bin\Release\QFEBridgeTest.tlb

This is the error:  Strong Name validation failed

This file is also in the same folder:  QFEBridgeTest.tlb

So the paths are correct.
0
AleksAuthor Commented:
Thanks for the help !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.