Link to home
Start Free TrialLog in
Avatar of BCHCAdmin
BCHCAdmin

asked on

TP-Link Media Converter Issues

I have two TP-LINK MC210CS media converters.  They are connected via single mode fiber that runs between two buildings and when connected the link light (FX) lights fine.  On one end, the media converter is connected via CAT6 cable into a network switch. On the other end we have tried connecting directly to a laptop and also to a switch and we are unable to get connection on either.  They are both exactly the same model and we have the switch in “force” mode.  We are using C2G SC-SC 9/125 duplex singlemode patch cables.   I have also tried connecting the two media converters together with just the patch cable and directly into the switch but not having success.   Any ideas?  Fiber is not my expertise....
Avatar of Gerwin Jansen
Gerwin Jansen
Flag of Netherlands image

What is the status of the TP Link and the TP RX light?
Avatar of BCHCAdmin
BCHCAdmin

ASKER

Both the TP Link light the RX light are on.  The RX light blinks occasionally.
Both sides have TP Link and RX on right?
You have the fiber cables connected cross (RX-TX and vice versa)?
Laptop with same cable works on the switch? Use same cable for laptop on the other end and a 1:1 patch cable from switch to converter?
Correct - I have the RX/TX hooked up correctly.  If not, I get to FX Link light on.  This morning I replaced the two TP-Link GB media converters with 100MB Transition Networks media converters and it works correctly.  Hooking back to the TP-Link GB converters and it fails again.   Are there switch settings that need to be looked at?
With the same fiber and GB converters, link lights are on as well? Switch set to auto? Possibly the fiber cannot handle Gb, only 100Mb or the issue is on the TP side. Can you check the switch setting to auto first?
I smell lousy ends on the fiber optic cables!  Unless they are cut perfectly and polished, you'll have massive degradation of the optical data stream and 100Mbps will be far more forgiving than 1Gbps.
Were the optical cables cut by anyone or are they commercially made, including the ends?
Found 2 Trendnet GB Media Converters and they work fine.  Getting 1GB connection at the other end just fine.  Waiting for the vendor to call me back about the TP-Link converters to see if there is some other settings I'm not aware of.
You could check the TP devices with a sort fiber if you have one. Length could be an issue.

Are the new converters set to 'auto'? Found them at you local store? :)
ASKER CERTIFIED SOLUTION
Avatar of BCHCAdmin
BCHCAdmin

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Clear, at least good to hear that your new set up is working.
Found no solution - sending units back.