El Capitan no sound

Macbook Pro
15-inch, Mid 2012
OS X El Capitan
Processor 2.3GHz Intel Core i7
Memory 16GB
Graphics Intel HD Graphics 4000 1024 MB
500GB SATA hard drive

I upgraded to El Capitan and now it seems I have no sound.  I press the keyboard buttons up Sound / down Sound but the only thing that displays is the speaker symbol and a 'cancel' symbol.  

I Googled for some solutions that did not help.  I went to System Preferences > Sound but anything I messed around with didn't help.  It's like El Capitan thinks I have no physical (internal) speakers.  I went to Terminal and typed 'sudo killall coreaudiod' but that did nothing.  I restarted the mac but that did not fix this.  I reset PRAM but no bueno.

The solutions here did not help me at all.

Help me.
LVL 18
Kyle SantosCustomer RelationsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
10.10.1 is supposed be out imminently with a fix.
0
strungCommented:
Do you have sound if you safe boot?
0
Kyle SantosCustomer RelationsAuthor Commented:
I have not tried that.  What is your recommendation on how to safe boot?
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

strungCommented:
Just boot while holding down the shift key.
0
strungCommented:
You could also try an SMC reset:

https://support.apple.com/en-ca/HT201295
0
Kyle SantosCustomer RelationsAuthor Commented:
No sound in safe mode.
SMC reset did not make any difference either.

:(

10.10.1 is supposed be out imminently with a fix.

Wow they messed up THAT bad?  :|
0
strungCommented:
Try with bluetooth off. Do you have any USB externals connected? If so, try disconnecting. Make sure you don't have Airplay turned on.
0
strungCommented:
Your upgrade to El Capitan may be coincidental. This link suggests plugging and unplugging headphones from the jack or blowing compressed air into the headphone jack:

https://discussions.apple.com/thread/6508303
1
strungCommented:
Also, check out the Apple KB:  https://support.apple.com/en-ca/HT203186

It suggests that you go to the sound prefs panel and make sure that "internal speakers" is selected, volume is up and not muted.

If "internal speakers" is not an option, the link above has other suggestions.

There are also more suggestions here:  https://discussions.apple.com/thread/6655270
1
Kyle SantosCustomer RelationsAuthor Commented:
Try with bluetooth off. Do you have any USB externals connected? If so, try disconnecting. Make sure you don't have Airplay turned on.
Bluetooth is never on.
No USB externals are connected.
Airplay is not turned on.

Your upgrade to El Capitan may be coincidental. This link suggests plugging and unplugging headphones from the jack or blowing compressed air into the headphone jack:

https://discussions.apple.com/thread/6508303
I plugged my headphones in and played a song from iTunes.  I have sound.  I unplugged the headphones and played the song from iTunes.  Same problem with no sound.

It suggests that you go to the sound prefs panel and make sure that "internal speakers" is selected, volume is up and not muted.
Weird.  I plugged my headphones back in, played a song in iTunes, I went into my Sound preferences, selected the output of my headphones, selected the option to show the volume in the taskbar, and confirmed it was still playing the song.  I paused the song, unplugged my headphones and played the song and it's now playing through my macbook speakers.

I'm not sure why that was necessary to fix this.  My internal speakers are now showing up in Sound preferences.  0.0
0
strungCommented:
There is a physical switch in the headphone jack which turns off the internal speakers when the headphone plug is inserted. Sometimes the switch gets stuck and plugging and unplugging the plug into the jack gets it unstuck.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kyle SantosCustomer RelationsAuthor Commented:
Brilliant.  And easy. haha.

Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.