Console stopped working for VM in vSphere client

Hi,

I have been accessing a VM on a host via the vSphere console with no issues and a few minutes ago started getting the following error when I tried to bring it up:

Unable to connect to the MKS: Login (username/password) incorrect.

I googled this and the references really didn't apply to this situation.  This is on Esxi 5.5.0 and the host VM OS is W2008 R2.  After rebooting the VM I am able to get in to it via the Remote Desktop Connection client.

?

--Ben
Ben ConnerCTO, SAS developerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ben ConnerCTO, SAS developerAuthor Commented:
I use IP addresses to access the host in this case (10.0. range).  No, no DNS changes have been made.  It was working 2 hours ago and now is not.

The VM version is vmx-09.

--Ben
Ben ConnerCTO, SAS developerAuthor Commented:
Oh..  other VMs on that host I can access in the console tab with no issues.

--Ben
JluchtCommented:
Have you tried to access the vm via the web portal and the vSphere Client?
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

JluchtCommented:
is this the solution you found?

Open /etc/vmware/config with a text editor.
Add this: vmauthd.server.alwaysProxy = “TRUE”

Check your firewall config/network setup. This error is caused by your vSphere client not able to communicate with the ESX/ESXi host directly.

All “Unable to connect to the MKS:” errors are network issues. Do not be fooled by the mention of certificate issues…
Ben ConnerCTO, SAS developerAuthor Commented:
Haven't tried the web interface.  Trying that now.

I'm puzzled that it would work with one VM on the same host/switch and not this one, and this one was working about an hour ago.

Will let you know how the web ui goes.

--Ben
JluchtCommented:
I would also check the firewall settings on the Win2k8 Server.
Ben ConnerCTO, SAS developerAuthor Commented:
It's disabled.

Interesting.  The web UI can see the machine.

--Ben
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
this can happen if you have many console sessions open.

can you repeat the issue ?
Ben ConnerCTO, SAS developerAuthor Commented:
Certainly.  I am in vSphere client 5.5, accessing a single VM on a host.  Hm...ok, that's interesting.

There was a vmware-clientintegrationplugin-5.5.0 that the web UI wanted installed, so I did.  Now the VM is visible in the console in vSphere.  

Not sure why it suddenly stopped working w/o the plugin, but it is working now.

Thanks, guys!

--Ben

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JluchtCommented:
No problem, Please be sure to mark this question solved!
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
select your own question as the answer.
Ben ConnerCTO, SAS developerAuthor Commented:
Stumbled across the answer while I was working with others.  It may help someone else in the future.

--Ben
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.