Cannot browse the Internet

Have a laptop (Windows 7 x64 standalone)which cannot browse the Internet.  Troubleshooting steps taken:
-Cannot ping domains by name only by IP address, but nslookup of various domains are successfully.
-Tried from both wireless and wired networks - same result
-Checked "hosts" file, no unusual entries
-Winsock reset procedure
-Was using 8.8.8.8 as DNS server, tried Comcast DNS servers, but nslookup works so it isn't the DNS server.
-Inserted an entry in the "hosts" file -  8.8.8.8   google.com  (then tried to ping google.com, no luck)
-Uncommented 127.0.0.1 localhost and pinged localhost still get "Ping request could not find localhost".
???
WebccAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Try the following


Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

Let us know if that helps.
0
Anand PandyaCommented:
If you have a another laptop you can plug it and check if it works there.
If it works check the IP Configuration of that machine and on the one it is not working

Also check with the different browser and setting under the browser.
If DNS is checked then it is fine. If you are using internet on home network check on properties of device(Router) if there are no restriction on your laptop particularly.
0
ForFracksSakeCommented:
Take the above advice and flush your DNS cache. Try using an 'Incognito' window or 'Private Browsing' window, depending on your browser and see if the pages come up.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

WebccAuthor Commented:
No luck.

Nothing to do with the browser.  Cannot ping by domain name.  Ping looks at the hosts file first I believe, but if I create entries they don't work even local ones.  Nslookup tests from the first DNS server first and that works.  Tried the "netsh int ip reset", that is what I listed as winsock reset.  However, tried it a second time.  Apparently, something is corrupted.
Have other computers on the network both wired and wireless that are working fine.
0
ForFracksSakeCommented:
Can you supply the domain name? I don't want to ask for too much information, but I can troubleshoot better with at least that.
0
WebccAuthor Commented:
Just trying to ping "google.com" or "yahoo.com".  Resolver problem, but nslookup works.  May be time to reimage.  Would like to know what is causing this however.
0
David Johnson, CD, MVPOwnerCommented:
go into device manager, delete your network adapter and reboot, repeat your tests it may be resolved.
0
WebccAuthor Commented:
Nope.
0
CompProbSolvCommented:
Try the following:
Start
Cmd
nslookup
google.com
exit
ping google.com


And report the results....
0
nobusCommented:
can you still download updates?  i had such a case on a new install, and all i needed to do is waiting for the updates to install

 i assume you have no errors in device manager - or in event viewer, related to this?
0
JohnBusiness Consultant (Owner)Commented:
Open cmd.exe with Run as Administrator and run SFC /SCANNOW twice. Shut down, start up and test.

If that does not work, you need to consider a Windows 7 Repair Install. For this you need the Windows 7 DVD for the system. Here is a Seven Forums tutorial to assist.

http://www.sevenforums.com/tutorials/3413-repair-install.html
0
WebccAuthor Commented:
Yes I already tried the SFC utility last night.  Will run the repair install.
0
JohnBusiness Consultant (Owner)Commented:
Please let us know after the Repair Install. It may, in the end, be better long term to back up and reinstall. If you do this, consider upgrading to Windows 10 after the fresh install.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
what abou my post webcc ?
0
WebccAuthor Commented:
Nobus,

Cannot download updates and no errors in logs.  Going to reimage.
0
nobusCommented:
ok -let's see what it results to
0
WebccAuthor Commented:
The ultimate fix was to reimaged the laptop and to move on. Thanks everyone!
0
JohnBusiness Consultant (Owner)Commented:
@Webcc - thanks for the update and I was happy to help.
0
kadadi_vIT AdminCommented:
Please Check the Antivirus installed on this PC. For testing purpose uninstall that Antivirus and firewall application and then check what you get.

Regards,
VK
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.