EXCHANGE 2010 - Send as from a shared mailbox

Hey guys,

Some users have requested to send as from a shared mailbox. I have created a shared mailbox, the user account linked to this is disabled. I have given the particular users full permissions and full send as permissions to this shared mailbox. The shared mailbox automapped to their outlook. Then tried to create a new email, then send FROM this shared mailbox but got a bounce back saying they didnt have the correct permissions.

Any ideas?

exchange 2010, outlook 2010.
out2getyouAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Shweta GoelCommented:
Hi,

Check Your Outlook running in Cache Mode. If yes then try outlook is not running in cache mode.

Regards
0
out2getyouAuthor Commented:
Hi, I dont understand your solution.
0
Alexei KuznetsovMicrosoft Outlook MVPCommented:
First of all, you need to make sure that the OAB is updated on both Exchange Server and clients (automapped mailbox appearance is not enough). This may take a couple of days if you didn't force it manually.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

WatawCommented:
Try

set-mailbox sharedmailboxname -GrantSendOnBehalfTo "user name"
0
systechadminConsultantCommented:
ask them to not use the cached entry. remove the cached entry from outlook and then again fetch it from the GAL
0
Muhammad BurhanManager I.T.Commented:
Add-ADPermission -Identity "username" -User mailboxname -AccessRights ExtendedRight -ExtendedRights "send as"
0
Amit KumarCommented:
Better you do one thing, login in OWA with permitted user then use from Option in OWA and try to send mail using from address of SHared mailbox. It will give you exact idea that permission is working or not.

On the other hand in Outlook you check that outlook is configured with Cache mode or Online mode. best practice to use Outlook in cache mode but sometimes it create issues when things are about to replicate. So for once you can disable Cache mode and then try it. Follow this article to disable/enable cache mode.
0
out2getyouAuthor Commented:
thanks guys, this is now resolved. It was indeed the cached record causing the problem.
0
out2getyouAuthor Commented:
thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.