Avatar of AXISHK
AXISHK
 asked on

Cisco switch configuration

already configured my switch as attached file. When I try to ping the vlan ID, it returns with timeout. However, "ip routing" has been put in the configuration.It seems that my VLANs can't be communicated with each other. Any idea ?

Tks
Switches / Hubs

Avatar of undefined
Last Comment
AXISHK

8/22/2022 - Mon
Predrag Jovic

No file attached. :)
And idea - did you configure default gateway on host(s) to be Interface VLAN IP address?
AXISHK

ASKER
Do I need to have at least one workstation on VLAN 3 before I can ping the vlan 3 interface in the switch ?

Tks
Dump.txt
Predrag Jovic

You need active port in that LAN. As long as no active ports in VLAN,  interface VLAN is down (host or active trunk port with assigned VLAN should be enough).
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Predrag Jovic

You can check if interface vlan is down issuing command
#sh ip int brief

Vlan20                     192.168.20.1    YES NVRAM  down                  down
AXISHK

ASKER
yes, they are down.

No device is attached as it is a new switch.

Do you mean I need to configure a port as trunk port to allow vlan 3, 6, ... to pass through for testing.

In fact, we will put four switches in a stack so I believe no trunk port is needed...

Tks
ASKER CERTIFIED SOLUTION
Predrag Jovic

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
AXISHK

ASKER
So, there should be at least on host plug into the VLAN before I can ping the VLAN interface ?? I can't explicitly turn on VLAN interface on .. ?

Tks
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Predrag Jovic

You can try:
#interface vlan 1
#no autostate
That should bring interface vlan up, but it does not work on all switches (at least not on all interfaces).
AXISHK

ASKER
Tks