network 2 vistas

i am trying to network 2 vista laptops via ethernet. they are connected with a crossover cable.
i have turned on network discovery and file sharing on both machines and turned off both firewalls.
they are in the same workgroup.
i can ping each way to their ip addresses shown in ipconfig.
they show both connected to a private, unidentified network and but they don't seem to see each other. their network maps don't show any connection.

what am i missing?
alk444Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Advanced Sharing options in Network and Sharing Center and turn on network discovery, remove password protection if you need to.
0
alk444Author Commented:
password protection is off and as i said, network discovery is on.
0
JustInCaseCommented:
Try in Windows explorer's address bar to enter ip address of other PC
\\169.254.10.12
or hostname
\\PC2
0
Become an IT Security Management Expert

In today’s fast-paced, digitally transformed world of business, the need to protect network data and ensure cloud privacy has never been greater. With a B.S. in Network Operations and Security, you can get the credentials it takes to become an IT security management expert.

alk444Author Commented:
i entered the ip address and got a 'windows cannot access' message.
i click diagnose, i get: ip is not set up to establish a connection on port "File and Printer sharing (SMB)" with this computer.
0
JustInCaseCommented:
Most likely some of the network files are corrupted.
Try - sfc /scannow
0
rindiCommented:
Make sure you give each PC a unique IP in the same subnet. Something like:


PC1:

IP:               192.168.0.2
Subnet:     255.255.255.0

PC2:

IP:               192.168.0.3
Subnet:     255.255.255.0

Personally I'd suggest using a router, which would make things much easier, and you could then access the internet via the router on both PC's.
0
alk444Author Commented:
i ran sfc on both machines. 1 was clean, other had 2 errors, fixed.
still same error message when i try to explore.

the ip's are
169.254.119.140
169.254.119.141

the subnet's are
255.255.0.0
255.255.0.0

i don't want to connect to the internet, but how would i connect a router to just connect the 2 laptops?
0
rindiCommented:
Change the IP's to what I suggested. What you have now are APIPA addresses.

With a router you can use DHCP which would assign the IP's automatically, and you wouldn't need a crossover cable. It would also allow you to connect more than 2 PC's with each other. Routers are cheap, and most of them include at least a 4 port switch, so you could attach at least 4 PC's to one Router.
0
alk444Author Commented:
ok i changed the ip's

still same problem
it seems both are trying to do something with printing.

if i explore from pc1 to ip of pc2, i get a folder containing a "printers" folder

if i explore from pc2 to ip of pc1, i get the error:
ip is not set up to establish a connection on port "File and Printer sharing (SMB)" with this computer.

i will try the router later. i would like to understand what is going on with the direct connection first.
0
alk444Author Commented:
some progress:
i found a youtube video that tells how to turn on sharing.
https://www.youtube.com/watch?v=Y5l8eADpnB8

after following that procedure on pc2, i can now see it's C: drive from pc1, but i can't access anything, apparently because of permissions. the video tells how to set permissions, but not in enough detail to get it to work. i get an error saying 'you do not have permission to access the file...'
0
Davis McCarnOwnerCommented:
The first question is what folder(s) have you shared on each PC?
Under the advanced sharing, check the box to "Turn on sharing so anyone with network access can read and write files in the Public Folders"
When the sharing does start working, you'll be able to see a folder named Users from each of the other PC's.
(BTW, Vista will really hate you trying to share the root folder (i.e. C:\) of any drive!)

Also, using a router is an excellent idea and, as long as you leave the WAN/Internet port on it empty, they won't have internet.  If you do that, set the ip and dns back to automatic and choose a WORK network if it prompts you.
0
alk444Author Commented:
Davis McCarn, tnx for the reply.

i was sharing the C: drive and i did get a warning message.
i removed that share and shared C:\Users instead.
it's Share Permissions form shows user 'Everyone' has Full Control

exploring pc2 from pc1 shows:

Network
-CHRISTINE
+c
-Users
+All Users
+Default
+Default User
Public
William
Printers

the only item i can access is Default and even in that i can only access the first level.

i assume using a router/switch would not help with this permissions problem. right?
0
alk444Author Commented:
i see that the indentation was lost in my last submission. here's another try.

Network
..-CHRISTINE
..+c
....-Users
......+All Users
......+Default
......+Default User
...... Public
...... William
.... Printers
0
Davis McCarnOwnerCommented:
I told you:
Under the advanced sharing, check the box to "Turn on sharing so anyone with network access can read and write files in the Public Folders"
because then the users folder should have appeared across the network and let you open the Public folder to see all of its subfolders.  You should also then have full read/write access to those folders (Documents, Pictures, etc.).
This is the BEST TEST of whether network sharing is working.
Afterwards, if that is working, you can right-click on the users Documents (or any other) folder and Share With; though you have to add everyone under specific people and change it to Read/Write if you care to.  Be warned that doing so will let anyone on the network edit or delete anything they care to!  I usually create an XFER folder and share it so people can copy files to and from each other and warn them to never leave anything sensitive in that folder.
BTW, you need to unshared Users before you try this.
0
alk444Author Commented:
ok, in the 'network and sharing center', i had been setting the networks on both machines as private and turning on network discovery and file sharing.

now leaving them as 'public networks' and turning on 'public folder sharing' i can now see down into the Public folder.

is there no way to set things up so that i can see every thing under Users, not just stuff in Public?

btw, the networks in the diagram in 'network and sharing center' are labeled 'Unidentified network' on both machines. is this normal?
0
Davis McCarnOwnerCommented:
If you are still using a crossover cable then, no, it will stay an unidentified network though private is better than public and you should still be able to access the public folders.
Sharing the Users folder is problematical as many of the subfolders (especially <username>\appdata) have special permissions.  I would recommend against it; but, if you REALLY want to, you'll need to choose advanced ant tell Windoze to Replace all of the child permissions.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
alk444Author Commented:
tnx for the help. i don't really want to set up this way, but i am trying to learn about windoze networks.

next i will try it with a router/switch.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Operations

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.