Having issues pushing out Barracuda Outlook Add-in Ver 4.1.88.0 for message archiver via GPO.

I have two policies linked to an OU with all of our user's PC's.  They are linked in the following order:

Policy #1
Computer Settings Disabled.

User settings
Logon script with batch file that will find the older Barracuda Outlook Add-in(3.6.20.0) and uninstall it using "msiexec /x" command


Policy 2#
Computer settings
Assigned Software to install the Latest Barracuda Outlook Add-in 4.1.88.0

User settings
Logon Script with Batch file to install latest Barracuda Outlook Add-in(4.1.88.0) at logon using "msiexec /i /quiet"


I already tested the logon Scripts and they are working.  I confirmed that my Test PC is having all the Policies applied by using gpresult /r.

The problem is that it takes a LONG time for the Add-in to install.   After gpupdate /force, and a reboot and a login, it can take up to 5 minutes for it to install.   If i were to open outlook anytime before these 5 minutes are up, it would corrupt the install of the Add-in and then i would have to manually uninstall /reinstall to force it.


When i have pushed older versions of the Outlook Add-in in the past, it would never take this long using the same senario.


Now I have notice that on every PC, when i run RSOP.MSC, I can still see the Older Barracuda Add-in ver. 3.6 still listed in Computer Configuration/Software Settings/Software Installation:
Rsop Result

I have tried opening up gpedit.msc on the local machine and it is not showing up at all in the local policy.  But for some reason it does in RSOP.msc

Its very strange and NO-Where in my domain/GPO's is the older add-in (3.6.20.0)  software assigned to any policy.

I have a feeling that this is whats causing all the slow installation issues.

Please help

any ideas for me?

Below you will find both scripts just so you can determine if its the way the scripts are written thats causing the issue or not:

(Barracuda Uninstall Older version(3.6.20.0)script)

@echo off
setlocal

call :GetFileVersion FileVersion "C:\Program Files (x86)\Barracuda\Message Archiver\Outlook Add-In\BmaSearch.exe"
if "%FileVersion%"=="3.6.20.0" goto Uninstall
call :GetFileVersion FileVersion "C:\Program Files\Barracuda\Message Archiver\Outlook Add-In\BmaSearch.exe"
if "%FileVersion%"=="3.6.20.0" goto Uninstall
echo BmaSearch.exe not found in a version that needs uninstalling.
goto :eof

:Uninstall
echo Uninstalling Barracuda Add-In ...
msiexec.exe /x "\\mydomain.local\SysVol\QpayNet.local\Policies\{B7D55D1D-7D20-46EB-92F9-FEB42BABC41E}\Machine\Scripts\Startup\BmaOutlookAddIn-3.6.20.0_x86.msi" /quiet


goto :eof
:GetFileVersion <ByRef Variable> <Path>
set __FilePath=%~2
if not exist "%__FilePath%" (
      set %1=
      goto :eof
)
set TempFile=%Temp%\wmic.tmp
wmic.exe DataFile WHERE Name='%__FilePath:\=\\%' GET Version /format:list >"%TempFile%"
for /f "delims=" %%a in ('type "%TempFile%" ^| find.exe "="') do (
      for /f "tokens=1* delims==" %%u in ("%%a") do set __FileVersion=%%v
)
echo '%~2': %__FileVersion%
set %1=%__FileVersion%
goto :eof





Barracuda Install Latest Outlook Add-in (4.1.88.0)

@echo off

REM check if Barracuda Add-In is already installed
if exist "C:\Program Files (x86)\Barracuda\Message Archiver\Outlook Add-In\BmaSearch.exe" (
GOTO EXIT
) else (

if exist "C:\Program Files\Barracuda\Message Archiver\Outlook Add-In\BmaSearch.exe" (
GOTO EXIT
))

REM INSTALL ADDON
msiexec /i \\mydomain.local\SysVol\QpayNet.local\Policies\{B7D55D1D-7D20-46EB-92F9-FEB42BABC41E}\Machine\Scripts\Startup\BmaOutlookAddIn-4.1.88.0_Win32.msi /quiet

:EXIT
exit




Yes i have already opened up a case with barracuda but i doubt they will be any help here since its clearly a GPO/Microsoft issue
JB BlancoSr Systems EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
Could all be very simple: The delay: starting with windows 8 (and higher), logon scripts are delayed by default for exactly 5 minutes. What client OS are you at? This delay is configurable.
Then: Don't use logon scripts for installations, that's a real mistake. Use startup scripts instead, those run with system rights, while logon scripts just run with user rights and cannot install things unless the user is an administrator.

Also please note: startup scripts on win8 and higher will only run after restarts. They will not run after shutdown followed by power-on. This is by design.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JB BlancoSr Systems EngineerAuthor Commented:
Interesting,

where do i configure the delay for the scripts?
0
JB BlancoSr Systems EngineerAuthor Commented:
nevermind, i needed to install administrative ADMX to my Policy Definitions Folder.

I just now changed the scripts to Startup Scripts instead.  I'll keep you posted
0
JB BlancoSr Systems EngineerAuthor Commented:
seems to work better now thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.