Hyper-V Virtual Machine User Account Permission Issue

I am trying to attach a VM's IDE Controller, DVD drive to an ISO file on a remote server's USB drive.  I created a share to the USB drive with full access rights to everyone.  I can browse to the ISO file but get the following permissions error when I try to Apply: Failed  to add device 'Virtual CD/DVD Disk'  User Account does not have permission to open attachment.

What am I missing?
HeilandSAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
This is often seen. Just copy the ISOs that you are going to use to your hyper-v. Will save you time and nerves.
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Configure Constrained Delegation for CIFS.

Once configured recycle the VMMS service on the Hyper-V host. Make sure Hyper-V Management is closed before running the above steps.

Once done, any ISO or VHDX file can be mounted in a VM on that host from the source server.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HeilandSAuthor Commented:
Thanks Philip.  That worked easily.
SD-WAN: Making It Work for You

As bandwidth requirements and Internet costs grow, businesses naturally want to manage budgets by reducing reliance on their most expensive connection types. Learn more about how to make SD-WAN work for your business in our on-demand webinar!

McKnifeCommented:
Funny, for me it didn't work, had the same problem. I went through these steps and additionally through these similar steps here: http://fixmyitsystem.com/2012/10/Hyper-V-Iso.html
What Hyper-V  version do both of you run?
I run 2012R2.
HeilandSAuthor Commented:
I am running Hyper-V Server 2012 R2
McKnifeCommented:
Weird. I can go through these steps one by one and it does not change anything for me.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.