We help IT Professionals succeed at work.
Get Started

null coming in rpm name

201 Views
Last Modified: 2015-10-18
HI,
I am using maven rpm plugin to generate an rpm out of my project like :
 <plugin>
                <groupId>org.codehaus.mojo</groupId>
                <artifactId>rpm-maven-plugin</artifactId>
                <version>2.0</version>
                <extensions>true</extensions>
                <configuration>
                    <name>flocksnippet</name>
                    <packager>Voodoo</packager>
                    <copyright>2015</copyright>
                    <version>3</version>
                    <group>Application/Collectors</group>
                    <release>2</release>
                    <packager>aad</packager>
                    <classifier>wqeqw</classifier>
                    <detail>sda</detail>
                    <releaseProperty>asdas</releaseProperty>

Open in new window


I tried giving values to all the parameters inside configuration but the rpm that gets generated has the name :
flocksnippet-3-null.x86_64.rpm
Dont know why null is coming in the name..
On sites i read its the realease number which i have specified. But still its coming as null.

Thanks
Comment
Watch Question
Top Expert 2015
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE