? can't see a remote desktop window when it is resized?

I have screwed up my remote desktop app such that it is off the screen and I can't see it except when it is full sized and fills all 4 of my displays.

With other applications, things like right click on the icon in the tray will give a move option.
but, this time, I don't get that option. Move is greyed out.

Keyboard tricks like alt+Spacebar or WindowKey+arrows are also not working. I'm guessing that when remote desktop has focus, the keys are opperating on the active window inside the RDP window.

are there registry keys that I can fix?
or some other tricks?
thanks
Phil
LVL 1
philkryderAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael MachieFull-time technical multi-taskerCommented:
You have already exhausted the normal methods to move a window back onto an active monitor. So, let's try a few other things 'out-of-the-box'.

Perhaps view it on all (4) monitors and see if you can select the 'Restore' icon (the one in the middle of the 'minimize' and 'X' icons). If you are able to click that then the window may shrink down to where you can move it to your primary display.
If you are able to 'restore' down in in size, then try the normal methods you have already tried. You are correct that if in full screen these commands won't have any effect - try again after resizing the window.

Another idea is to force the size of the RDP session resolution using the settings within your RDP icon, assuming you are using the Remote Desktop Services program or 'mstsc'. If this is the case, see below:
1) R-Click the RDP icon
2) Select 'Edit' from the menu
3) Select the 'Display' tab
4) Move the slider under the 'Display Configuration' section towards the left-most, or 'Small, setting.
5) optionally - deselect the 'Use all my monitors for the remote session' option.
6) Connect and see how it goes.

If not using a pre-configured RDP icon, or instead are just launching the 'mstsc' or 'Remote Desktop Connection' program:
1) Launch the program
2) Before connecting, click the 'Show Options' button beneath the field where you type the Server info.
3) Continue on from Step #3 above to change the display settings.
0
philkryderAuthor Commented:
so - the process of writing the question must have triggered something in my mind.

I edited the RDP for the session and change the "Apply windows key combinations" to "Only when in Full Screen Mode"
It might also work to "On this computer"
then the window key plus arrows work.

The critical thing that make RDP different from run-of-the-mill applications is that once the RDP session has focus, the keystrokes and mouse moves are applied "inside" the RDP session unless you change the "Apply windows key combinations" setting to not use "On the remote computer" - Once the window is back into view on a monitor, you can drag it arround with the mouse.
Once you get it back on screen, you can re-edit the RDP setting.
Phil
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
philkryderAuthor Commented:
the above suggestions from Machinet were not helpful.
They were close. They did suggest editing the RDP app.
But,
They did not address the fact that keystrokes were applied "inside" the remote session window.

I could re-size the window just fine. But that didn't help because the window was off of all the screens and not reachable with a mouse.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Michael MachieFull-time technical multi-taskerCommented:
If you are all set you should close the question and mark one of the answers as the solution. If it was your own work that solved it then select your own comment as the answer.
0
Danny ChildIT ManagerCommented:
If you start your (non-visible) rdp session, and then press ALT <space>, and then the M key (for Move), you should then be able to lean on the arrow keys (i'd suggest the Left one first).  You have to press the M key fairly quickly before the menu times out.

This should move the RDP window around on your desktop, until hopefully it's visible.

Take care when it is, as you may need to click the mouse to lock it in place when it appears.  
May be worth a practice with a window which you *can* see first.  Try it with Notepad, for instance
0
philkryderAuthor Commented:
the process that I used worked. It explains why.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.