How do I set up MailEnable std server to send all outbound email through a relay / anti-spam service?

I have installed Mail Enable Std Version 9.  I need to have my incoming and outgoing email relayed through an 3rd party service.  How do I set this up in Mail Enable?

In MailEnableAdmin, under Servers > Services & Connectors > SMTP, i rt click / Properties and I see a "relay" tab, but that only deals with what clients are allowed to relay (ie: users sending mail to the ME server).  I also see an "outbound" tab, but that only deals with limiting threads & message size.

How do I tell the ME server to send all outbound mail through a 3rd party authenticated service?

Thanks.
LVL 1
cef_soothsayerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cef_soothsayerAuthor Commented:
I found a tab called "Smart Host" that looks like where you set up outbound relay.  But when I configure it for my relay host, the mail will not send.

This is my outbound SMTP log from the send attempt:

[10/14/15 18:13:57]****************** LOG FILE STARTED *******************
10/14/15 18:15:17      SMTP-IN      DE6E55121F3D4512ACFE840ABD769514.MAI      232      127.0.0.1                  220 DOMAIN.COM ESMTP MailEnable Service, Version: 9.00-- ready at 10/14/15 18:15:17      0      0      
10/14/15 18:15:17      SMTP-IN      DE6E55121F3D4512ACFE840ABD769514.MAI      232      127.0.0.1      EHLO      EHLO MAILSVR      250-DOMAIN.com [127.0.0.1], this server offers 4 extensions      123      14      
10/14/15 18:15:17      SMTP-IN      DE6E55121F3D4512ACFE840ABD769514.MAI      232      127.0.0.1      AUTH      AUTH LOGIN      334 VXNlcm5hbWU6      18      12      
10/14/15 18:15:17      SMTP-IN      DE6E55121F3D4512ACFE840ABD769514.MAI      232      127.0.0.1      AUTH      {blank}      334 UGFzc3dvcmQ6      18      26      SENDER@DOMAIN.COM
10/14/15 18:15:17      SMTP-IN      DE6E55121F3D4512ACFE840ABD769514.MAI      232      127.0.0.1      AUTH      {blank}      235 Authenticated      19      18      SENDER@DOMAIN.COM
10/14/15 18:15:17      SMTP-IN      DE6E55121F3D4512ACFE840ABD769514.MAI      232      127.0.0.1      MAIL      MAIL FROM: <SENDER@DOMAIN.COM>      250 Requested mail action okay, completed      43      31      SENDER@DOMAIN.COM
10/14/15 18:15:17      SMTP-IN      DE6E55121F3D4512ACFE840ABD769514.MAI      232      127.0.0.1      RCPT      RCPT TO: <RECIPIENT@OTHERDOMAIN.COM>      250 Requested mail action okay, completed      43      34      SENDER@DOMAIN.COM
10/14/15 18:15:17      SMTP-IN      DE6E55121F3D4512ACFE840ABD769514.MAI      232      127.0.0.1      DATA      DATA      354 Start mail input; end with <CRLF>.<CRLF>      46      6      SENDER@DOMAIN.COM
10/14/15 18:15:20      SMTP-IN      6B575875D1FF4CFF9A9B7454B69BF2EE.MAI      232      127.0.0.1      QUIT      QUIT      221 Service closing transmission channel      42      6      SENDER@DOMAIN.COM


And this is the debug log:

[10/14/15 18:13:57]****************** LOG FILE STARTED *******************
10/14/15 18:13:57      ME-I0143: Service Loading Configuration Providers
10/14/15 18:13:57      ME-IXXXX: Loaded Address Map Provider
10/14/15 18:13:57      ME-IXXXX: Loaded Authentication Provider
10/14/15 18:13:57      ME-IXXXX: Loaded MEAISM Configuration Provider
10/14/15 18:13:57      ME-IXXXX: Loaded MEAIDP Directory Provider
10/14/15 18:13:57      ME-IXXXX: Loaded MEAILS Configuration Provider
10/14/15 18:13:57      ME-IXXXX: Loaded Postoffice Configuration Provider
10/14/15 18:13:57      ME-I0073: MEW2KDNS Initialized to use DNS Servers (10.1.1.xxx 208.67.222.222)
10/14/15 18:13:57      ME-IXXXX: No plug-in DLL configured
10/14/15 18:13:57      ME-I0141: Service Starting
10/14/15 18:13:57      ME-I0139: Outbound Mail Agent Initialised
10/14/15 18:13:57      ME-I0140: Standard Inbound Mail Agent Initialised
10/14/15 18:13:57      ME-I0082: Service binding to all addresses on port (25) for IPv4 family (2). Requires authentication 0
10/14/15 18:13:57      ME-I0085: Service (Alternate) binding to all IPv4 addresses on port (587). Requires authentication 0
10/14/15 18:13:57      ME-I0144: Service Completed Loading Agents
10/14/15 18:13:57      ME-I0065: [SYSTEM] Initalised Send Message Master Thread
10/14/15 18:13:57      ME-IXXXX: Initalised Recv Message Master Thread
10/14/15 18:13:57      ME-IXXXX: Initalised Recv Message Master Thread
10/14/15 18:13:57      ME-I0065: [SYSTEM] Resetting queued messages
10/14/15 18:13:57      ME-I0076: Listening for connections
10/14/15 18:13:57      ME-I0076: Listening for connections
10/14/15 18:13:57      ME-I0066: [SYSTEM] No outgoing message files in queue.
10/14/15 18:15:17      ME-I0135: Authenticating User:SENDER@DOMAIN.COM using Authentication Provider Credentials
10/14/15 18:15:17      ME-I0108: [232] Relay Granted: Sender has authenticated.
10/14/15 18:15:17      ME-I0149: [232] DE6E55121F3D4512ACFE840ABD769514.MAI was received successfully and delivery thread was initiated
10/14/15 18:15:18      ME-I0018: [DD7F70B61B244194B053552F7C723EF3.MAI] Outbound message from ([SMTP:SENDER@DOMAIN.COM]) requeued as [C79270CD20754F1CB84746EF87458787.MAI] to the target domain [OTHERDOMAIN.com]
10/14/15 18:15:18      ME-I0122: Domain to [tx.rr.com] will be smart hosted by the Connector to [smtp.postmarkapp.com:587]
10/14/15 18:15:18      ME-I0026: [C79270CD20754F1CB84746EF87458787.MAI] Sending message
10/14/15 18:15:19      ME-IXXXX: [C79270CD20754F1CB84746EF87458787.MAI] DNS resolved to the following record: IP Address=xxx.xxx.xxx.xxx, Family=2, Type=1, Protocol=6
10/14/15 18:15:20      ME-I0074: [232] (Debug) End of conversation
10/14/15 18:15:40      ME-E0038: [C79270CD20754F1CB84746EF87458787.MAI] Communications Error: Socket connection to smtp.postmarkapp.com failed (error 10060). The host was either not contactable or it rejected your connection. Socket Family = 2; Host=xxx.xxx.xxx.xxx; Port=587
10/14/15 18:15:40      ME-E0059: [C79270CD20754F1CB84746EF87458787.MAI] Message Delivery Failure. Attempt (0): Could not connect to mail server for domain (OTHERDOMAIN.com). The remote mail server could not be contacted at this time. Message has been requeued.
cef_soothsayerAuthor Commented:
It looks like the ME server is still trying to contact the recipient domain to send the email.  Why?  It should be sending through the relay!
cef_soothsayerAuthor Commented:
The mail relay was stup correctly, but my ISP was blocking port 25 and 587.  Fixed now.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.