Emails stuck in Exchange 2010 queue!

Been scratching my head on this all day. I have bunch of emails stuck in the outbound queue. Restarting the server makes it work for 30 mins and then it starts again. I can see the emails in the queue. I ran the troubleshooter and found the following (see attached snapshots).

Event ID is clean no error or anything. Its the strangest thing. SPF record is up to date. We use Mcafee SaaS to filter, that works fine. There is an internet connector there as well. Just the strangest thing....

How do I even troubleshoot this, where are the errors? Any ideas? I cannot keep rebooting the server ever 30 mins...
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SpiderPigAuthor Commented:
Here are the photos, I have also created a new connector...
Mal OsborneAlpha GeekCommented:
Looks like a DNS problem. looks to be set up correctly, it has MX and A records in place that look OK.

What are you using as a DNS server?  If you  have your own, is it resolving from root hints, or relying on some other DNS server for queries?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SpiderPigAuthor Commented:
Yeah I figured its a DNS, but its so strange, it worked before just fine. I have implemented the second section of this article, and so far it has been working properly for over an hour.

I manually specified the external DNS to I will give it few more hours and see how it goes. Thanks for the prompt response.
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Mal OsborneAlpha GeekCommented:
That seems a useful workaround, but you probably should fix your DNS server
Naushad shaikhIT Consultant - Messaging SupportCommented:
If I am not wrong, you are using a mxlogic service as a smarthost for your email system. It seems your mxlogic is configured for sending and receiving too. As mxlogic is a third party service you DNS server don't have A record for it locally. there is problem in sending connector outbound email.Mxlogic must come after you DMZ there same port must me open on the firewall. I not sure what screenshot you have attached that is from the edge or hub server. If it is Edage server, it is not able to resolve mxlogic there is some problem in firewall setting or ISP DNS.
SpiderPigAuthor Commented:
Good morning folks,
I confirmed the fix solved the issue. I have double checked the DNS and all seems to be fine. I could ping MX logic prior to this issue, and after the fix. I am really confused as to what was the real source of this. If I had to guess, its something related to a recent MS Exchange patch. I never had to enter a DNS manually  on Exchange, nor was anything changed with this Exchange or DNS... Its the strangest thing I tell ya, but having to deal with MS for the last 15+ years. Its never too strange... ;)

Thank you all for your help.
SpiderPigAuthor Commented:
Solution found, link provided.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.