BIND won't start

When I run
"service named restart"

Open in new window

BIND fails with no error message.

When I run
bash -x /etc/init.d/named start 

Open in new window

it fails with the following problem.  How/where do I fix this?

+ echo -n FAILED
FAILED+ '[' color = color ']'
+ echo -en '\033[0;39m'

Open in new window


Using CentOS.
jeff_zuckerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jmcgOwnerCommented:
That's all you get? The first executed command is to echo the word FAILED?

I'd expect to see a trace of it calling into the "functions" script or something like that. Have you looked at the file /etc/init.d/named? Does it look reasonable?

If so, then I'd begin to suspect that there's a .bashrc file or BASH_ENV environment variable that's causing bash to run a startup script when it really shouldn't be. If so, the failure when you run interactively may actually be unrelated to why it fails when run as a service invocation.

I'd look for the actual invocation of named in the startup script and see if executing it gives any visible complaints, then work outward from there to identify the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jeff_zuckerAuthor Commented:
Thanks to your advice I was able to rule out problems in the named.conf file. Problem turned out to be only loosely related.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.