x230 Thinkpad win10 ,no bluetooth!

I have this thinkpad with win10 all drivers in device manager installed with no errors or notices.
The problem is that I do not have any bluetooth in there ,when I press fn+f5 I get airplane mode activated.
I installed lenovo hotkeys app. Wifi is working well. It's just that the bleutooth seems to be not installed at all.
I searched the BIOS for any hints ,nada!
LVL 10
aboo_sAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jason CrawfordTransport NinjaCommented:
Man you're not alone.  Windows 10 is giving Lenovo headaches across the board.  Are you sure your wi-fi adapter supports bluetooth?  Open up Powershell and run this to find the exact model:

Get-NetAdapter

The good news is they're dirt cheap and can be easily swapped out in less than 5 minutes if you want to upgrade.
ivan rosaCommented:
Have you looked in "device manager" to see if there's anything awaiting for drivers? or in settings For anything in regards Bluetooth?
Worst case you laptop was not equipped with it but on the sweeter news a USB dongle will cost you around $15
McKnifeCommented:
Did you take the time to look at Th Lenovo driver page and see if a win10 driver is available? If none is available, try windows update it might have one.

I could try on our x230, but it's on the road right now.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

aboo_sAuthor Commented:
Thank you all for your replies.
ivan, in device manager all looks good.
McKnife, I installed every possible driver in their page!
keyser, I don't think it's win10 related cause the problem was the same before I upgraded from win7.
I have purchased a bluetooth adapter for my x230 from aliexpress and when I wanted to install it I was surprise to find one already inside, see I thought my laptop had none!
Question is how to activate it!?
I think if I can manage to run Lenovo wireless app, the one that let's you switch on and off wifi
then I would have something to turn BT on. I just can't seem to be able to install it!
ivan rosaCommented:
aboo,

 if you say there are no confilcts then in the drivers nor windows 10 is the one giving you the problem then you should see the menu in
Pc Settings > Devices > Bluetooth
bt.JPG
McKnifeCommented:
There's a win10 x64 driver for bluetooth: https://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/g4wh01ww.exe
If you install it, what does device manager show?
aboo_sAuthor Commented:
ivan rosa,
I do not have BlueTooth in this menu!!
McKnife,
I installed the driver you suggested(although I already have installed), it says ready to use but still all the same!!
McKnifeCommented:
Hm... I have access to an x230 next week, tuesday and could verify with win10. In the meantime, ask Lenovo.
Jason CrawfordTransport NinjaCommented:
What I think you're talking about is the hotkey integration feature that allows you to switch bluetooth off and on by pressing Function+F5.  Try running the update tool found on the support website to download the hotkey integration package plus all dependencies.  If that doesn't work, you can try downloading the software directly from the Lenovo site.

Also, when you click the little message icon in the bottom, right-hand corner, do you see Bluetooth as an option?

message.png
aboo_sAuthor Commented:
I tried updating with lenovo tool, no  luck.
tried directly installing the software, looks like installed all ok, but still fn+f5 is controlled by what seems
like a win10 menu, anyway no BT in there!
Jason CrawfordTransport NinjaCommented:
Ok now we're getting somewhere.  Function+F5 pulls up the same stupid Windows 10 menu on my laptop.  Try using this app instead:

https://www.microsoft.com/store/apps/9wzdncrfj12p
aboo_sAuthor Commented:
I installed the app.
Under network settings no BT as well.
Jason CrawfordTransport NinjaCommented:
Ok do this.  Open Powershell and run this command:

Get-NetAdapter | fl InterfaceDescription

Open in new window


Tell me what kind of wi-fi adapter you have and let's just ensure it does actually include Bluetooth support.
aboo_sAuthor Commented:
InterfaceDescription : Intel(R) 82579LM Gigabit Network Connection

InterfaceDescription : Intel(R) Centrino(R) Advanced-N 6205
aboo_sAuthor Commented:
I think my laptop has it's own independent BT piece.
https://support.lenovo.com/ie/en/documents/pd024304
Jason CrawfordTransport NinjaCommented:
That's all I got man.  Unless anyone else can chime in you may have to call Lenovo on this one.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aboo_sAuthor Commented:
Thanks a lot
I will close this question now.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.