installing php5-mycrypt in ubuntu message unable to locate package

hi all

i am trying to install php5-mycrypt package in ubuntu but it always give me the message unable to locate package.
kindly find the attached screen shots.
i tried
apt-get update
 apt-get install php5-mcrypt

but still same issue

kindly help
sources.list1.png
lsb.png
sources.list2.png
sl_aiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MurfurFull Stack DeveloperCommented:
That tells me that the package you are looking for is not located in the repositories you are connected to.

A quick Google give shows me that you need to add the UNIVERSE repository with
$ sudo add-apt-repository universe

Ref: http://askubuntu.com/questions/483186/unable-to-install-php5-mcrypt-on-ubuntu-14-04
sl_aiAuthor Commented:
Dear

i already run the command  sudo add-apt-repository universe
kindly check attachment for output.

still i cannot install php5-mycrypt.
i still have the same issue
add-apt.png
MurfurFull Stack DeveloperCommented:
I was beginning to think that the actual package name is different or your local package lists are out of date then it hit me and I'm sorry - I've been utterly blind! You have a typo in your command:

$ sudo apt-get install php5-mycrypt

remove the 'y' from mycrypt  and the package is then correctly names as php5-mcrypt

You should update your lists too, before you run the install, just to be sure you are up to date:

$ apt-get update

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Vimal DMSenior Software EngineerCommented:
Hi,

Try this...it might have installed...

sudo ln -s /etc/php5/conf.d/mcrypt.ini /etc/php5/mods-available
sudo php5enmod mcrypt
sudo service apache2 restart
sl_aiAuthor Commented:
thank it worked.
it is very painful to be a beginner.
2 weeks trying to solve this problem and it turned out a typo issue :(
thank you
MurfurFull Stack DeveloperCommented:
Don't worry - we've all been there. Happy to have been able to relieve your pain!
Have a good weekend, NOT having to worry about this... :)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.