SQL Filter in Grid view adding "N" Before Criteria

Every time I do a search in my SSMS on any table in grid view when I place my Criteria in the filter column, it is automatically placing a "N" at the beginning of what ever I put in. It is doing this for every field. In the SQL view I have to back out the "N" for the search to complete.
SQL-Screen.JPG
LVL 1
BSAS_ITGuyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike EghtebasDatabase and Application DeveloperCommented:
having N is harmless. It is forced there because of your sql server setting to handle international characters.
0
BSAS_ITGuyAuthor Commented:
Yes Mike but It forces me now to have to use SQL view every time to back out the "N", if I back it out in grid view which is quicker it adds it right back in, where can I turn this off?
0
Jim HornMicrosoft SQL Server Developer, Architect, and AuthorCommented:
The column's data type is likely some kind of unicode, such as nvarchar, nchar, which as Mike said handles a larger character data set optimized for international characters as opposed to the non-unicode varchar, char data types.

If international characters is not something you have to deal with, then change the data type to varchar or char.
Otherwise you're stuck with using N'  '.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mike EghtebasDatabase and Application DeveloperCommented:
I had it wrong when I said there is sql server setting to handle. But, JIm is right as you can see in the image below.NCharThere is also under Tools/Option/General/Internation setting where you have two options:
1. English
2. Windows setting.     <-- with this option, it will follow whatever windows environment setting is.
0
BSAS_ITGuyAuthor Commented:
Thanks Jim, This answer helps me to move forward.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.