Outlook 2016 and Exchange 2010 over http

Hello,

I just installed Office 2016 and I am trying to make it work with out Exchange 2010 running on SBS 2011. I managed to get it working in the office, but when I try to connect over the internet I have to issues.

1. It shows error for the self signed certificate - because it resolved everything from autodiscover.company.com and the cerficate is for remote.company.com
2. The second one is that it does not remember the password - It asks me to type it everytime i start Outlook 2016.

Thank you
goliveukAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott CSenior EngineerCommented:
Self-signed certificates are generally not recommended for production environments because they will make browsers issue a warning about the certificate not being issued by a recognized CA (Verisign, Thawte, etc.)

Exchange 2010 uses Autodiscover.  You need to add that to your cert.

Best suggestion is to purchase a proper cert, install it and configure your virtual directories.  When/if you get a "real" cert you will want to delete your Outlook profiles and create new ones.
Naushad shaikhIT Consultant - Messaging SupportCommented:
Outlook2016 use MAPI on HTTP default , you neeed to disable it on client PC

To disable MAPI/HTTP and force RPC/HTTP, set this key on the client computer.

HKEY_CURRENT_USER\Software\Microsoft\Exchange

DWORD = MapiHttpDisabled

Value = 1
Scott CSenior EngineerCommented:
Forcing Outlook to use RPC over HTTP should work but you are better off setting your environment up correctly rather than hacking the registry on your clients.

You need to get a certificate from a recognized CA and you will head off more problems down the road.
Cris HannaSr IT Support EngineerCommented:
While I agree that the self signed certs are no longer the best option, you do not need a trusted cert that includes  autodiscover.  Autodiscover is a service not a host name.   Google for SBS Susan Bradley and autodiscover   I'll try to post the link later.
David Johnson, CD, MVPOwnerCommented:
1. Get rid of any CNAME or A records for “autodiscover”, and any wildcard “*” records in the public DNS zone. This is a critical step, so don’t just drift past it.
2. Build the SRV record to look like this:

Service: _autodiscover
Protocol: _tcp
Port Number: 443
Host: remote.smallbizco.net
http://www.thirdtier.net/2011/06/setting-up-autodiscover-for-sbs-2011/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.