Exchange 2013 Public Folder "Send As" Permissions

We have an exchange 2013 server setup with two domains. Domain.com is the primary and domain2.com is a secondary domain. All mail routing etc works and we have a few users that have domain2.com as the primary email address.

The issue I am having has to do with public folders send as permissions. We have a PF named info and it is mail enabled. The email addresses attached are info@domain.com and info@domain2.com the primary address is the @domain2.com address. When I give a user send as permissions to this folder they can only send using the info@domain.com address. I get the error:
You do not have the permission to send the message on behalf of the specified user. Error is [0x80070005-0x0004dc-0x000524].

Open in new window

When using the info@domain2.com address. Do any of you have any idea why this is and do I have to do something to allow this?
LVL 7
Thomas WheelerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
This seems very strange and you should only be able to Send As the Primary SMTP Address (if you have proper permissions). This seems like a caching issue. Have you tried to do this with the Outlook client in Online mode rather than cached mode?

Also have you tried to check the primary smtp to @domain.com and then back to @domain2.com?

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas WheelerAuthor Commented:
I don't think it's a caching issue as I can update the send as permissions on a different folder and it's instant. But I can give it a try. I have changed the primary address back and forth and get the same result
0
Thomas WheelerAuthor Commented:
you are right this seems to be a cache issue. If I disable the cache I can send as but if I re-enable it I can only send if the primary address is set to domain.com. Do you know how to update the cache so this will work?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Thomas WheelerAuthor Commented:
Thanks. that worked if I disable the cache.
0
Will SzymkowskiSenior Solution ArchitectCommented:
ok cool. So that means its either the OST file or the Outlook profile. Likely the OST if you just needed to disable cached mode.

Will.
0
Thomas WheelerAuthor Commented:
it's strange I tested on a few machines and it works if I disable caching but I want to use caching. It seems silly that I would have to create a new profile everytime I make permission changes. Is there a way to get this to update with out doing that?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.