Office Web Apps 2010 on Sharepoint 2010 Windows Server 2012 installer fails

When running the setup.exe I immediately get the error that not all the Windows Server Features or Role Services are installed.
I ran the prerequisiteinstaller from the Sharepoint 2010 install and everything shows installed and configured.
I ran a powershell command that was also supposed to enable all the roles and features.

Add-WindowsFeature Web-Server,Web-Mgmt-Tools,Web-Mgmt-Console,Web-WebServer,Web-Common-Http,Web-Default-Doc,Web-Static-Content,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Security,Web-Filtering,Web-Windows-Auth,Web-App-Dev,Web-Net-Ext45,Web-Asp-Net45,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Includes,InkandHandwritingServices,NET-Framework-Features,NET-Framework-Core,NET-HTTP-Activation,NET-Non-HTTP-Activ,NET-WCF-HTTP-Activation45

I had previously made sure the following were enabled:
TCP port Sharing
Message Queuing Activation
TCP Activation
Named Pipes Activation

Desktop Experience
Ink and Handwriting Services
Ink Support
Windows Powershell Integrated Scripting Environment (ISE)
XPS viewer

I think office might be installed on this server but not sure if that would cause this issue or not.
What else needs to be installed?
glong3008Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rainer JeschorCommented:
Hi,
there might be a couple of things:
1. SharePoint 2010 with SP2
Only the ISOs of SharePoint 2010 including SP2 will install on Windows Server 2012

2. .NET Framework 3.5
Can you verify that .NET 3.5 is installed as a pre-req through Windows features?

3. SharePoint installation
Have you installed SharePoint beforehand on that server? Office Web Apps 2010 have to be installed on a SharePoint machine - whereas the 2013 version has to be installed without SharePoint on that box.

HTH
Rainer
glong3008Author Commented:
I finally gave up, uninstalled 2010 and installed 2013 and then installed Office Web apps 2013 on a new server.
Perhaps your first answer was the issue. Does that mean if only the ISO's will install that not all the roles will install for Office Web App to be able to install?
Rainer JeschorCommented:
Hi,
from my experience I had a lot of issues that basic features are not installed properly on new Windows Server 2012 and 2012R2 boxes - especially the .NET Framework 3.5.
SharePoint and OWA 2010 do not use .NET 4 as it did not exist when they started development / beta phase.
And as SharePoint 2010 / OWA has been released 2010 and Windows Server 2012 in 2012, the software did not yet support the new OS - you have to use an updated ISO package which included SP2 of SharePoint so that the installer knows about the new OS features (and restrictions / security hardenings).

KR
Rainer

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.