Windows 8.1 and 10 / Network and Sharing Center / Active Network Name and Type

I'm seeing that the Network Type (Public or Private) is not enabled to be clicked.  So, whatever type of network, Public or Private seems to be fixed/static with no flexibility.  
All the cases here are Ethernet-connected networks.

If one goes to mmc for Windows 8.1

Start / Search Programs and Files
enter:
mmc <enter>
[Console opens]
menu:
File / Add/Remove Snap In..
add:
Group Policy Object
OK
Expand Local Computer Policy
Select:
Computer Configurations / Windows Settings / Security Settings /
      Network List Manager Policies
On the right, select Unidentified Networks (double click)
      Choices:
      Location Type:
            Not Configured
            Private
            Public
      User permissions
            Not Configured
            User can change location
            User cannot change location
And, similar choices are provided user Identifying Networks and All Networks.

I believe that setting up the network type does work here.
But User permissions don't seem to work in that the network type in the control panel isn't lit up as a link.

How does one get the user permission to actually be active / workable?

We have seen strange results when the network cable was intermittent.  Network settings (like the above) change with no notice....
LVL 27
Fred MarshallPrincipalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
windows 8/8.1
open pc settings
network
connections
find devices and content off - public network
                         on  - private network
common to windows 8+
regedit
hklm\softwre\microsoft\windows nt\curentversion\networklist\profiles
if you expand profiles you will see a list of GUIDs {lots of letters 0-F}
go to the one where the proflie name matches your current network
Change the Category value to:
Public = Value 0
Privae = 1
Domain = 2

Override -- local security policy secpol.msc
Network list manager policies \ click on your network name

Windows 10
right click on network
network
left click on network
network settings
ethernet
network
find devices and content on - private off - public on
Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings you can change it here as well
 
https://tinkertry.com/how-to-change-windows-10-network-type-from-public-to-private
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fred MarshallPrincipalAuthor Commented:
Thank you David!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Operations

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.