Can't setup teradici connection broker for Amazon web services

I'm setting up the PCoIP connection manager from teradici for a zero client/AWS solution and I can't pass connection diagnostics from the connection manager. I've followed the instructions from teradici, listed below, but dns resolution fails for corp.amazonworkspaces.com. I can ping 8.8.8.8 and www.google.com from the connection manager instance and best I can tell security groups are properly set within AWS. I have 8.8.8.8 set up as a secondary DNS in the connection manager. I feel like I'm missing something really simple, or maybe I don't even understand the "directory domain" that the broker is asking for during setup. I do know that I can't resolve corp.amazonworkspaces.com from my PC, but it is listed as my diretory within AWS.

http://www.teradici.com/web-help/Connecting_ZC_AWS_HTML5/TER1408002_Connecting_ZC_AWS.htm#03_DeployPCM.htm
sdholden28Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
1. you need a public domain name
2. set an A record or a CNAME record that points to the public address of your teradaci instance.
0
sdholden28Author Commented:
It's  not the teradici instance that needs resolving. I'm familiar with basic dns zone files and records. I can connect to the teradici instance without issue and a host name for it is irrelevant as I can provision the zero clients with the external ip if necessary. The teradici instance runs a custom Ubuntu variant from teradici and must be able to resolve Corp.amazonworkspaces.com to facilitate the connection from zero client to aws. Corp.amazonworkspaces.com is not resolvable outside of the aws environment, but it is supposed to be resolvable via internal dns provided by the associated amazon vpc. Currently I cannot resolve it, even though Internet access and common domain names resolve without issue. The issue is somewhere within the aws setup, I'm just out of ideas as to how and where to look to fix it.
0
Shalom CarmelCTOCommented:
Have you tried to ask the teradici support? what do they say?
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

sdholden28Author Commented:
I am still waiting for a response from them. I also have an open ticket with AWS.
0
sdholden28Author Commented:
This turned out to be a DNS issue within AWS. I had deployed the teradici instance to a VPC that had no route to my domain directory. I worked through the issue with Amazon support to get to a solution. After deploying the instance to the right VPC and setting up the proper rules on the AWS side, everything went right through.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sdholden28Author Commented:
No reasonable solutions or direction were ever provided from others. I resolved it on my own.
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
AWS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.