We help IT Professionals succeed at work.
Get Started

Windows 10 VPN connection setup - allow other people to use this connection not working. Network Sign-in not showing on logon screen.

pyotrek
pyotrek asked
on
15,642 Views
1 Endorsement
Last Modified: 2015-10-16
There are 2 common ways to setup VPN connection in Windows 10.


1. Network and Sharing Center-->Setup a new connection or network-->Connect to a Workplace.
2. Start-->Settings-->Network & Internet-->VPN-->Add a VPN connection


Both of them have issues.

What I want to accomplish is to setup VPN connection to workplace that would show up as an "Network Sign-in" option on logon screen, and with "Use default gateway on remote network" disabled.

When you use the option 1. - you can choose "Allow other people to use this connection" - and as a result you do see the "Network Sign-in" icon on logon screen - but you are unable to have "Use default gateway on remote network" disabled. When VPN connection is setup this way - when you try to go to properties for IPv4 nothing happens. Also the PowerShell fix that allows for disabling the default gateway on remote network (SplitTunneling) does not work.

you get following error:

Windows PowerShell
Copyright (C) 2015 Microsoft Corporation. All rights reserved.

PS C:\Users\USER1> Set-VpnConnection -Name VPN -SplitTunneling $true
Set-VpnConnection :  The configuration cannot be applied to the local user VPN connection VPN. : The system could not
find the phone book entry for this connection.
At line:1 char:1
+ Set-VpnConnection -Name VPN -SplitTunneling $true
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (VPN:root/Microsoft/...S_VpnConnection) [Set-VpnConnection], CimExceptio
   n
    + FullyQualifiedErrorId : VPN 623,Set-VpnConnection



With the option 2. You can disable the default gateway on remote network using the PowerShell, but there seems to be no way to "Allow other people to use this connection"

Does anyone else found a way to correct this?
maybe there is a Powershell command that could help.

I have tried and failed with following:

PS C:\Users\USER1> Set-VpnConnection -Name VPN -AllUserConnection $true
Set-VpnConnection :  The configuration cannot be applied to the global user VPN connection VPN. : The
system could not find the phone book entry for this connection.
At line:1 char:1
+ Set-VpnConnection -Name remote.optinode.com -AllUserConnection $true
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (VPN:root/Microsoft/...S_VpnConnection) [Set-VpnConnecti
   on], CimException
    + FullyQualifiedErrorId : VPN 623,Set-VpnConnection



I actually have a working VPN connection on my Surface 3 Pro that I just upgraded to Windows 10 with both options working - but it transferred from Windows 8.1 when those "bugs" did not exist.
Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 1 Comment.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE