Link to home
Avatar of craig Fenn
craig Fenn

asked on

nim question

Trying to make a mksysb resources directly from the client.
I do a smit nim_mkres trying to create a mksysb directly from the client..
client = genfintk
master=bhnim01
I get the following error in smitty..


0042-001 nim: processing error encountered on "master":# tail /var/adm/ras/nimsh.log

   0042-006 m_mkbosi: (From_Master) connect Error 0

0042-008 nimsh: Request denied - bhnim01

I get this from the nimsh.log on the client...

# tail /var/adm/ras/nimsh.log
Fri Oct 16 13:25:28 2015        count equals 4
Fri Oct 16 13:25:28 2015         got stderr port 1022
Fri Oct 16 13:25:28 2015        get_auxport: timelag is 1
Fri Oct 16 13:25:29 2015        success: we got 1st write query is 0
Fri Oct 16 13:25:29 2015        success: we got 2nd write local id is 00F928AE4C00
Fri Oct 16 13:25:29 2015        success: we got 3rd write remote id is 00F96EE44C00
Fri Oct 16 13:25:29 2015        success: we got 4th write command is /usr/lpp/bos.sysmgt/nim/methods/c_nimpush "/usr/bin/lslpp" "-lcIqOu" "bos.sysmgt.nim.client"
Fri Oct 16 13:25:29 2015        passing OpenSSL setting of 0
Fri Oct 16 13:25:29 2015        error: remote value passed, 'bhnim01', does not match environment value 'bhnim01.bhs.org

I set up a similar client recently without issue..
Avatar of woolmilkporc
woolmilkporc
Flag of Germany image

Add the nimserver's IP address and short hostname to the client's /etc/hosts file and add the client's IP and hostname to the nimserver's /etc/hosts file (if not already present), so neither client nor server will  have to query the DNS (which will return the fully qualified hostnames).

Attention: You will have to delete and re-create the client definition on the client side and/or on the server side
depending on where you made the changes.
Make sure that /etc/niminfo is no longer present on the client after deletion (and before re-creation)
Forgot to mention: Make sure to have "hosts = local, bind" (or "local, bind4" if you don't have IPv6) in /etc/netsvc.conf so that the local repository will be used first for hostname lookup.
Avatar of craig Fenn
craig Fenn

ASKER

I did actually find the /etc/netsvc.conf was not configured from it's native form.
I changed it and restarted nimsh on both sides.
However, it still gave me the same error.
Thank you.. Good try.. I'll be off until Monday now..
ASKER CERTIFIED SOLUTION
Avatar of woolmilkporc
woolmilkporc
Flag of Germany image

Blurred text
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
I understand.. I won't be back at that site until Thursday..
I'll give it a try then.. Thank you.
You've always been helpful and a excellent resource.
As always.. Excellent solution.
Thank you.