How to change Ubuntu login screen

On Ubuntu 14.04, I have the login screen shown in the attached image. Two problems:

1) How do I remove users from this list. For example, I don't want the user "guest" to show. I don't want guests logging in at all. I don't even know where this guest account is coming from as I can't see it in /etc/passwd.

2) The 1st "Mark Foley" user shown is really an Active Domain user Authenticated via winbind. The problem is I have 10 such users, but I have to first ssh in remotely as that AD user before he/she shows up on this page. What I'd like here is simply a blank userId space and NO users shown at all! There's no sense it giving half the User/Password info away to anyone looking at the screen.
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan CraciunIT ConsultantCommented:
The login screen has nothing to do with /etc/passwd.
It's a package called lightDM.

How can you hide the users:
sudo mkdir /etc/lightdm/lightdm.conf.d/
sudo nano /etc/lightdm/lightdm.conf.d/50-myconfig.conf
Then type this:
[SeatDefaults]
allow-guest=false
greeter-hide-users=true
greeter-show-manual-login=true

Open in new window


Save the file, reboot.

HTH,
Dan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmarkfoleyAuthor Commented:
Dan, thanks, that worked. My system had only /etc/lightdm/users.conf, no /etc/lightdm/lightdm.conf.d/50-myconfig.conf. My user.conf file contains

#
# User accounts configuration
#
# NOTE: If you have AccountsService installed on your system, then LightDM will
# use this instead and these settings will be ignored
#
# minimum-uid = Minimum UID required to be shown in greeter
# hidden-users = Users that are not shown to the user
# hidden-shells = Shells that indicate a user cannot login
#
[UserList]
minimum-uid=500
hidden-users=nobody nobody4 noaccess
hidden-shells=/bin/false /usr/sbin/nologin

Open in new window

Putting your directives in this file did nothing. When I created /etc/lightdm/lightdm.conf.d/50-myconfig.conf with your directives, it worked.

Two questions:

1) where did you get this information? `man lightdm` and `man dm-tool` have none of these settings described. Nor are there manpages for users.conf or 50-myconfig.conf.

2) On the login page there is a white disk or white Ubuntu logo to the right of the login name - see image (I apparently I forgot to upload this in my original post). The solid disk means "Cinnamon desktop" whereas the Ubuntu-logo disk means "Ubuntu desktop". On this new login form you've helped me set up, it always defaults to Ubuntu desktop. How can I default it to the Cinnamon desktop? I want to save users a step from having to select it each time they log in.


Is the difference different versions of lightdm? Should I experiment with the settings in my users.conf or scrap that and user your 50-myconfig.conf?
ubuntuLogin.jpg
0
Dan CraciunIT ConsultantCommented:
1. Click on the link in my first post: https://wiki.ubuntu.com/LightDM
There, about 10 lines from the beginning of the page, you'll find this:
For example, if you want to override the system configured default session (provided in /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf) you should make a file /etc/lightdm/lightdm.conf.d/50-myconfig.conf with the following:
The rest of the options are below that.

2. I don't use Cinammon, but I think you'll find this interesting, from the same page:
Changing the Default Session
The default session is set by configuration in /usr/share/lightdm/lightdm.conf.d/ that session packages provide. If you need to override this you can set:

[SeatDefaults]
user-session=name
Where name is the name of the session .desktop file from /usr/share/xsessions/*.desktop.
0
jmarkfoleyAuthor Commented:
DanCracium:
Click on the link in my first post: https://wiki.ubuntu.com/LightDM
OK, thanks. That link did provide some info, and the /usr/share/doc/lightdm/lightdm.conf.gz file had lots of settings. Too bad there's no man page though.

Things seem to work OK, but one thing I'd like and I don't see a setting: If the user types in a userid, hits enter, and goes to the password screen, but the user doesn't enter a password. It appears to just stay on that screen forever (image). Do you know of any way to timeout the password screen?
2015-10-17-16.45.30.jpg
0
Dan CraciunIT ConsultantCommented:
Nope
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.