Server 2003 R2 reporting multiple 12292 and 10 VSS errors

My server running Server 2003 R2 has been reporting multiple 12292 and 10 VSS errors when the UniTrends agent calls to the Shadow Volume Provider for a VSS Snapshot. The server has the latest updates including SP2.
Thus far I have:
•      Checked vss writers using the vssadmin list writers command : All writers were stable with no errors
•      Checked providers using the vssadmin list providers command: Only the Microsoft Software Shadow Copy Provider appears
•      Tried to access C:\ properties > Shadow Copies but the window froze. I rebooted the server and was able to access it.
•      Verified that the HKLM\SYSTEM\CurrentControlSet\Services\swprv  parameter wasn't missing
Also reregistered the vss dlls using the following command:
cd /d %windir%\system32
net stop vss
net stop swprv
regsvr32 /s ole32.dll
regsvr32 /s oleaut32.dll
regsvr32 /s vss_ps.dll
vssvc /register
regsvr32 /s /i swprv.dll
regsvr32 /s /i eventcls.dll
regsvr32 /s es.dll
regsvr32 /s stdprov.dll
regsvr32 /s vssui.dll
regsvr32 /s msxml.dll
regsvr32 /s msxml3.dll
regsvr32 /s msxml4.dll
vssvc /register
net start swprv
net start vss

Here is a copy of the events:
Event Type:         Error
Event Source:     VSS
Event Category: None
Event ID:              12292
Date:                    10/17/2015
Time:                    12:11:08 AM
User:                    N/A
Description:
Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} [0x80080005].
Event Type:         Error
Event Source:     VSS
Event Category: None
Event ID:              10
Date:                    10/17/2015
Time:                    12:11:08 AM
User:                    N/A
Description:
Volume Shadow Copy Service information: The COM Server with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} and name SW_PROV cannot be started. Most likely the CPU is under heavy load. [0x80080005]
Do you recommend any other additional steps to diagnose and resolve the root issue?
Thank you for your assistance.
Eric MartinAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Sounds similar to issue in link below:

https://social.technet.microsoft.com/Forums/windowsserver/en-US/dbd2a8f6-c4fb-4412-969e-7b0ce940cd2d/volume-shadow-copy-operation-failed-for-backup-volumes

You may also have to install MS patch KB940349 (support.microsoft.com/kb/940349 )
Eric MartinAuthor Commented:
Hey Mohammed! Thanks for the response. I had checked that registry setting and reviewed that update. I noticed that the solution you posted does fix the issue in a lot of cases. I think the reregistering of the dlls might of fixed it in this scenario as a few backups have completed with no errors. I appreciate the help all the same. Have a great day!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Eric MartinAuthor Commented:
I found that after I reregistered the dlls for vss, I was able to complete various types of backups using the UniTrends backup agent with no errors.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.