DNS / Bind setup in CentOS 7

I am attempting to install DNS/Bind on a CentOS install that obviously did not include the DNS install option upon original install. I tried to install at the command line as a user with the proper authority and got this error.

___________

[root@localhost yum.repos.d]# yum install bind* -y
Loaded plugins: fastestmirror, langpacks
Could not retrieve mirrorlist http://mirrors.securehost.com/centos/ error was
14: curl#6 - "Could not resolve host: mirrors.securehost.com; Unknown error"

 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

_______________________

I updated the etc/yum.repos.d/CentOS-Base.repo file with the current CentOS working mirror site, http://mirrors.securehost.com/centos/ and not http://mirrorlist.centos.org since it appeared to be an old link. I still received the same error listed above. I need to resolve this hurdle and any similar noted issues so I can install Bind on CentOS 7.

FYI, this is a CentOS image running on VMWare Fusion so I can run it on my MacBook Pro with OS X Yosemite. I don’t think that matters but just in case.

Please help. Thanks.
Tech_20Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan CraciunIT ConsultantCommented:
>> Could not resolve host: mirrors.securehost.com; Unknown error"

Either your VM is not connected to the Internet or DNS is not configured properly.

HTH,
Dan

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Tech_20Author Commented:
Thanks, Dan. I'll double check the connectivity first & see if the default switch is OFF. That reminds me…I had to turn it on manually in the past.
Tech_20Author Commented:
I checked and the virtual machine has the usual wireless connectivity, no ethernet. Also, the last part of the error message reads...

Cannot find a valid baseurl for repo: base

Please keep in mind I already changed the repo file and included a current URL.
SolarWinds® VoIP and Network Quality Manager(VNQM)

WAN and VoIP monitoring tools that can help with troubleshooting via an intuitive web interface. Review quality of service data, including jitter, latency, packet loss, and MOS. Troubleshoot call performance and correlate call issues with WAN performance for Cisco and Avaya calls

Dan CraciunIT ConsultantCommented:
mirrorlist.centos.org works fine, you don't need to change it.

You just need to be able to access it.

What happens if you ping mirrorlist.centos.org?
Tech_20Author Commented:
I'll check that later today and update the results. Thanks.
Tech_20Author Commented:
As you mentioned, there is a connectivity issue that I am going to plan to resolve ASAP. The VM shows  connectivity but in terminal, it does not show an IP address.
Tech_20Author Commented:
The issue was that the VM showed connectivity but the CentOS image was not responding and didn't show any wireless connection in the Settings window.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSL / HTTPS

From novice to tech pro — start learning today.