Adobe PDF printer crashes when attempting to print reports in software

I work for a company named LIFO-PRO; we are an accounting firm that developed and sells licenses to an accounting software called LIFO-PRO. Our software was developed by the owner & president of LIFO-PRO; we have reports that are set up to be printed & saved as adobe .pdf files from the software. The software has printed to the adobe PDF printer in the past without error. At the current point in time, an error occurs and causes LIFO-PRO to crash while attempting to print reports to the Adobe PDF printer. We've created a workaround in the meantime; a program called doPDF operates as normal for printing & saving LIFO-PRO reports as .pdf files. We've advised our clientele to use doPDF for some time now, but I've come to the point where it would seem like a logical explanation and/or solution could fix the Adobe PDF problem. We've contacted Adobe regarding this in the past, and they "acknowledged" the issue present within our software. No response was ever given to LIFO-PRO explaining why this was; I've attached two screenshots of what occurs in our software at the point of LIFO-PRO crashing (the report screen shown is a standard report automatic printing menu which populates several reports to be spooled and printed automatically per checking the desired report boxes wanting to be printed). I've also added a 3rd screenshot that was taken on a 32-bit version of Windows 7 (LIFO-PRO uses a VB spreadsheet ActiveX component called Formula One; this error box does not appear when running on a 64-bit PC).
LIFO-PRO Software Print Menu ScreenLIFO-PRO-Adobe PDF Printer Software CrashTidestone Formula One Error Message
Lee RichardsonOwner & PresidentAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
If you are a local admin for your PC, the first test I would try would be to enable the administrator account, login to it, and see if that works.  If it does, its probably a permissions problem.  To do that, open an elevated CMD prompt and type net user administrator /active:yes<enter> .  Then log off and Administrator will be on the welcome screen.
0
Lee RichardsonOwner & PresidentAuthor Commented:
I tried that; the same issue still occurs.
0
Lee RichardsonOwner & PresidentAuthor Commented:
I have found the solution that involved an issue with the Adobe PDF's advanced printer settings. Thanks for your help, Davis.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Joe Winograd, Fellow&MVEDeveloperCommented:
> I have found the solution that involved an issue with the Adobe PDF's advanced printer settings.
> I figured out my problem on my own.

Hi Lee,

I'm glad to hear that you found the solution. I'm hoping you'll share it with us. This could be very helpful for other EE members who face a similar problem in the future. This is an extremely important aspect of the EE community — knowledge sharing. The answer you found may work for other software besides your own LIFO-PRO accounting package.

For example, here's a thread that I participated in last year on the same subject — the Adobe PDF printer did not work:
http://www.experts-exchange.com/Web_Development/Document_Imaging/Adobe_Acrobat/Q_28337715.html

I recommended other PDF print drivers as a work-around, and the asker tried doPDF, which worked fine. But note this comment:
I downloaded and installed dopdf-7, which worked just fine from all MS Programs and browsers as a selected printer. Quick too. I suppose I could stop here, accept what others on many forums (perhaps unknowingly) suggest is a bug in the latest version of Acrobat printer, and use the simple dopdf as a workaround, but ... I'd sure like to fix Acrobat.
Perhaps the solution you found would be helpful in this and other similar situations. Regards, Joe
0
Lee RichardsonOwner & PresidentAuthor Commented:
The Adobe PDF printers settings found under Printer Properties in the Control Panel need to be changed as follows:
1) Under the advanced tab, select the "enable enhanced printing features" check box
2) Under printing defaults, select an Adobe PDF output folder to send your PDF files to be printed/saved to. The "prompt for Adobe PDF filename" option appears to be a error-stricken option that can lead to the PDF Print driver and the windows "save as" dialogue box to become out of sync, leading to print spooling errors.
The above two steps allowed our program to resume normal Adobe PDF printing as we've normally done in the past.
1
Joe Winograd, Fellow&MVEDeveloperCommented:
Lee,
Thanks for taking the time to document your solution — much appreciated! Regards, Joe
0
Lee RichardsonOwner & PresidentAuthor Commented:
I figured out my problem on my own.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Acrobat

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.