Windows 10 breaks RWW SBS 2008.... sometimes

Hi,

Running a small office with SBS 2008 which runs great and under W7 no problems with RWW (IE 11, compatibility mode, etc).  I have "upgraded" a few machines to W10.  After the upgrade I check whether RWW still works.  A couple machines work, a couple don't.  I even try a clean install of W10 and try again for the machines that fail the connection.  Still doesn't work, IE 11 compatibility mode doesn't change the behavior.  Just times out and fails.  Even a local, on-premise session attempt fails.

My question is-  Where do I even start to look for answers?  On the terminal server log?  The client log?  Why do some work and others do not even though they are remarkably similar machines?  Network adapter issues?

I have done the tsweb.aspx on the server for the fix for W10 remote clients, but I am talking about the On-Premise RWW host machines that have been upgraded or clean installed and joined to the SBS 2008 domain.   ALso tried different ways to join the domain, http://connect, or just join, no difference in behavior.

https://social.technet.microsoft.com/Forums/en-US/fb9b0354-0eaf-4cfe-a6db-aace25fce12a/windows-10-and-remote-web-workplace-rdp?forum=winRDc

RWW is crucial for this office so I'd really like it to keep working under W10.

Restoring a machine from backup to W7 also restores RWW into the machine.
Eugene_PalmerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Eugene_PalmerAuthor Commented:
Hi,

Terminal logs show event 304 error 23005 user was able to authenticate but cannot connect.  We are using Webroot so I tried uninstalling (from the web portal), rebooting, disabling the firewall and still can't connect, even from another on-premise machine.

I'll try uninstalling Webroot from the server per a similar thread, but it's really not clear why some W10 local RWW hosts can be connected to but others cannot.
Eugene_PalmerAuthor Commented:
Microsoft PSS was not able to solve this.  The problem remains that a couple machines cannot be connected to from remote.  Port 3389 is unresponsive even over the LAN, though there is no firewall rule that denies it, and even if Webroot is uninstalled from both the server and client the connection cannot be made.

Again, the same machines worked fine in Windows 7.  

Webroot is installed on the Windows 10 machines where RWW does work correctly, there is no indication it is the problem.

Firewall rules are identical between the machines that work and do not work, there is no indication it is the problem.

Next step is to change out the network adapter itself and see if that works.
Eugene_PalmerAuthor Commented:
I have tried a new network adapter in a machine that does not accept the RWW connection.  That did not work.

I would be interested in hearing a method of resolving this.

The environment for the machines that are not connecting with W10 includes;
No firewall.
RWW works fine on some other Windows 10 Pro machines.
RWW works on all Window 7 pro machines.
Eugene_PalmerAuthor Commented:
When I run netstat -a on the Windows 10 machine that will not accept the RWW connection it shows

TCP 0.0.0.0:3389 machine Listening
as well as

TCP [::] 3389 machine Listening

But when I telnet from another machine on the LAN with

o machine 3389
I get-

connect failed

Remoting OUT of the problem W10 machine is successful.
Eugene_PalmerAuthor Commented:
Hi,

We can close this.  What was not obvious was that even when you "turn off" the firewall it does not seem to actually turn off, or maybe I was doing something out of sequence.

In any case, when I went into the firewall settings and checked 'Remote Desktop' and 'Routing and Remote Access' I was able to get into these W10 machines.  In fact the firewall rules were not the same as the machines that did work previously.

Though I still have one machine that really does have the same rules and will not connect, so there are still ways for this to break.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.