VirtualBox network interfaces failed to attach

Hello folks,

I have a "demo" virtual machine with Ubuntu OS for our sales people with gets updated periodically and then re-deployed (copied) to the client machines (Win 7 x64).

I am used to errors at first start about missing/wrong network adapters, which is "ok" - the clients' interfaces are different to mine (I update the VM).
This time I get errors: Failed to open/create the internal network ...
(VERR_SUPDRV_COMPONENT_NOT_FOUND)

The network adpater is online/active without errors.
Of course I tried rebooting and double checked the VM configuration and linked network adapters from the host machine.

In the first client the network config was fine, but when I start up the VM and I get the message, all adapters in virtual box are labeled "adapter 0" and empty! (I can go to the VM setting from the error screen).
After I cancel the startup and check on the VM settings again, all infertaces are fine again.

On one client notebook I suddenly was able to poweron the VM. I saw there wasn't enough free mem on the host client so I reduced it for the VM and it booted. Also I had the notebook detached from its dockingstation, but this shouldn't make any difference in windows or VM drivers.

I tried that on the second client notebook without any success.
I did the exact same things (checked available memory, detached from dockingstation,reboot etc)  but no chance :(

I also tried disabling all VM interfaces - then the VM startsup fine but this doesn't solve the issue; I need to address the vm-interal webserver by host-only IP.
Booting up with disabled network bridge but enabled host-only adapter also does not work and ends up in the same error message.

Does anyone have a clue on this?
Attached there is also a screenshot of the exact error message.

Starting a new version of the VM has never been such a pain. The old one was removed before.

I already found some hits on google but without success so far.
I.e. i removed the key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network "MaxNumFilters" and rebooted...

We use Oracle Vbox 5.0.4 on all machines - no differences in version.

Has anyone encountered this before?
2015-10-19-16_38_02-Oracle-VM-Virtua.png
SystemadministrationAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Have you installed the VirtualBox additions within the VM? Ubuntu doesn't install those automatically. Also, rather than copying the VM from PC to PC, use "File", "Export Appliance" to export the VM to a template, then import that on each PC using "File", "Import Appliance".

The current version of VBox is 5.06, so I'd also upgrade that. I had some networking and stability problems with VBox 5.04 on one PC which look as if they have been fixed with 5.06. Or use the latest 4.x version, where I never had any issues.
0
Dan CraciunIT ConsultantCommented:
In the network settings, is the VM connected to NAT? Cause from the error it sounds like it's bridged.

HTH,
Dan
0
SystemadministrationAuthor Commented:
Thanks for your replies!

I also thought about exporting the appliance, unfortunately this wasn't possible yesterday (deadline)..I will give that a try!
Updating the Version - I might try that; unfortunately all hits an google have had similar problems with version 3, 4 and 5 - I am not very confident that the 5.0.6 will fix this. But I'll give it a shot.

Can the VBox Tools make any difference during startup? These are guest-OS specific, my problem occurs during starting up the VM, so I can hardly believe it might be connected to these? Of course I am open to new suggestions! I am not sure right know, whether or which version of the tools are installed inside the VM.

@Dan:
I must say my informations weren't that clear:
There are two network adapters configured for the VM:
1st one is bridged via the client's GBit ethernet connection, 2nd one is host only.
Both adapters are up and functioning, no driver changes or anything..
Disabling the first adapter for the VM gives the same error as before, just with the second adapter in the error decription. Only disabling both during startup can start the VM but is useless..
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Dan CraciunIT ConsultantCommented:
Remove both, start the machine.
After a successful boot, shutdown the VM, add a single NAT interface, see if it boots.

If it does not boot, use a known good older backup/snapshot.
0
SystemadministrationAuthor Commented:
Well I guess ex-/importing as appliance won't work:
The export takes about 2hrs.
Also there is not enought free disk space on the clients for the appliance file + the exported VM.. And I don't think that importing the VM via network (appliance file in network share) will be less error-prone..

@Dan:
I will try to get hold of one client to test this "behaviour". The two clients I tested yesterday are out of office right now.
But:
If booting with NAT Interface works, what does this tell us?
If booting with NAT interface fails, too, then what? I updated the content inside the vm and need to deploy this to ca. 10 machines - there is no way I can repeate the update for each single machine/VM on the machines.

In the end there are still to open questions:
Why does this error occur, what is the background of that?
Why did it work on one of the to machines finally, even though both have had the same problems in the beginning?

As I said, I have had access to the clients within two hours, I repeated all the steps I tried on the first machine (adjusting ram/memory for the vm, taking it out of the dockingstation). I am absolutely clueless right now.
Of course I will try to get access to another client which is supposed to get the updated VM, but I can hardly get hold of it for hours of testing... :/
0
Dan CraciunIT ConsultantCommented:
>>If booting with NAT Interface works, what does this tell us?
It tells us that there is a problem with the Intel Gigabit interface. A NAT interface will work with pretty much any physical network card, a bridge is more finicky.
0
rindiCommented:
The VMware tools are basically drivers for the virtual hardware, like NIC's etc., so it is quite possible that without them not everything will work at startup.

Exporting/Importing should work, I haven't had any issues with it. Export to a USB disk, or network location if you don't have enough space on the host. It usually also won't take as long as it estimates at the beginning.
0
SystemadministrationAuthor Commented:
Sorry for the delay on my site - thanks again for your replies!

@Dan:
I couldn't try NAT mode, yet.
But before I tried to boot up only with Host-only (this is more important than the bridged interface), and I got the exact same error message for the Host-Only adapter..

@rindi:
The VM ist about 90GB huge, so exporting and importing take about 2hrs each - I can barely get hold of the clients.

What I also tried:
Creating a new VM (new .vbox file / config) and adding the existing virtual hard drive.
Same results/errors in the end, with both or only one single adapter activated...

What I found:
On my client I have a "VirtualBox NDIS6 Bridged Networkking Driver" listed in the GBit NIC preferences!
This is missing on the one faulty client!

Still I am not having any clue why the Host-Only adapter won't work..

I will reinstall VirtualBox and see if it makes any difference..

Do you get any clues out of the information above?
0
SystemadministrationAuthor Commented:
Just replying back to say: It's fixed!

Apparently the missing "VirtualBox NDIS6 Bridged Networkking Driver" was the main-reason for this error.
I uninstalled Vbox, rebootet, and then manually installed it again incl all components.

After the installation was done, I checked on the NIC preferences - the bridged driver now was successfully installed and activated!

On the first start of the VM I got an error about the host only adapter. When I checked the preferences on this one I saw there also is a "Bridged" driver but it wasn't activated. I activated this one (checkbox tick) and tried again - the VM immediately started up just fine!

To rule out every possible interference I had also stopped TrendMicro AV scan during the installation of vbox. Still after a clean reboot and active antivirus everything worked fine!

I don't know exactly why this happended in the first place..
Sometime during the initial installation or the update from 4.x to 5.0 the bridge driver did not get installed correctly.

Thanks for your assistance!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SystemadministrationAuthor Commented:
Experts' comments did not exactly point to the problem but kind of into the right direction :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.