Just after Login to windows after a few minutes MTI-MOTD.VBS error

After login to the windows, a few minutes later the user experience an error message. Below is the error. But it is intermittent. After I do a GPUPDATE /FORCE and restart the system it will go away. After a few more boots, it will come back again.

MTI-MOTD.VBS Error message
I suspect it has something to do with the logon script and conflict with some apps. Don't know what app. Or it could be the connection to the network is too slow and causes an error. I don't thing it is a WSCript error.

The system is a Lenovo x240 laptop. OS is windows 7 Enterprise 64bit. Loaded with ISAM ESSO startup and a logon script is pushdown during windows startup.

I hope someone here will be able to assist.
peterliongAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RobSampsonCommented:
What is MTI-MOTD.vbs doing with the InternetExplorer.Application object?  Are you automating a web page shortly after login for some reason?

Does it improve if you explicitly run the script using
C:\Windows\Syswow64\WScript.exe \\soe.sgnet.gov.sg\Netlogon\Live\MIT\MTI-MOTD.vbs

because if it's on a 64 bit system, it may be trying to run using the 64 bit Scripting Engine.  I find that using the 32 bit engine usually works better.

Rob.
peterliongAuthor Commented:
Hi Rob, I tried to run the vbs script it gave the same error. But when I run gpudate /force and restart it was ok again.

Yes, there is a script that was pushdown when login to initiate an Intranet webpage.
RobSampsonCommented:
Does the website actually need to be automated using the InternetExplorer.Application object?  If you don't need to automate the process of clicking buttons and things, if would be better do change that process to something like
Set objShell = CreateObject("WScript.Shell")
objShell.Run "iexplore.exe ""http://yourintranet.com""", 1, False

Open in new window


Or, since I actually have had integration issues with iexplore.exe loading from a logon script, I have created a Group Policy preference shortcut under
User Configuration --> Preferences --> Windows Settings --> Shortcuts
Type: URL
Shortcut Path: %StartUpDir%\YourIntranet
Target Path: http://yourintranet.com

This has not had any issues.

Regards,

Rob.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

peterliongAuthor Commented:
Rob, I am doing desktop support for this agency. They have a team for this pushdown of script. Anyways, this is the only user experiencing this. Not sure they have other users experiencing this.

As I say, when I apply gpupdate /force it goes back to normal. I  suspecting a policy issue. Seems like it has problem getting the policy.
RobSampsonCommented:
Ok. Is the policy applying a Trusted Sites assignment (for the location the script is being run from), or turning off IE protected mode? Maybe that's not happening properly. Can you run RSOP.msc on the client or check the Group Policy event logs and see what might not be applying?
peterliongAuthor Commented:
For the RSOP.msc I have to elevate it to run on local administrator mode. This way I cannot capture the policy for the machine. Also, the Group Policy event logs, how do I get them?
RobSampsonCommented:
OK, instead of RSOP.msc on the local client, try running the Group Policy Results Wizard from your administrative Group Policy Management Console.  From there you can target the machine and a specific user account.

On the client, run eventvwr.exe and then navigate down through Application and Service Logs --> Microsoft --> Windows --> Group Policy --> Operational
and have a look at errors in there.
peterliongAuthor Commented:
Rob, I've tried to download the log thru Application and Service Logs --> Microsoft --> Windows --> Group Policy --> Operational. It doesn't seem to have any error (Please see attached and change extension from txt to evtx), So how do I go from here?
RSOP.txt
RobSampsonCommented:
Hi, you mentioned this is the only user experiencing this issue.  Is that user this one:
SOE\MTI_WLLEE
with the canonical name of
CN=MTI_WLLEE,OU=User Accounts,OU=MTI,OU=Agencies

GPO's that have the most likelihood (based on their names) to affect this are:
USR-MTI-IESettings
USR-WOG-SUFInternet

If you add item-level targeting to those to not affect the username of MTI_WLLEE, then you can see whether the problem goes away, or makes it error every time.  I suspect it might make the script error every time, which means there would something in those GPOs that is getting overwritten over time and causing the error.  You should go through what those GPOs do and then monitor what is changed when the script error occurs.

Rob.
peterliongAuthor Commented:
I have no access to the GPO pushdown. Can only bring it to the backend team the gpresult and RSOP.log. But that will take time. I guess I'll try to re-inage the laptop and see how it goes. Will keep posted here later.
RobSampsonCommented:
Re-imaging may prevent the error happening, but you wouldn't know what setting was causing the issue.  If you could get an admin to capture the policy settings report from the Group Policy Management console when the error occurred, and when it didn't, you might see which setting(s) has changed.

Rob.
peterliongAuthor Commented:
Rob, I've tried to enquire from the team which pushdown the policies. They said it is not their end to troubleshoot and it lies on my end who is doing the desktop support. It think there may be alot of involvement on all the parties - the team that is responsible to pushdown the policies, the administrator and myself the desktop support.

Now the immediate problem I foresee is to capture the policy settings report from the Group Policy Management console.

1. The domain admin rights I have cannot run even MMC. I have to create local admin account in order to run MMC.

2. When I run the MMC, do I capture local machine or user account. But if I capture user account, I assume it will be my elevated local admin account not the current user account. So how should I do it?

3. If I do capture the policy, I don't think I'll be able to compare the situation through the event log. Too many. How to compare?

4. If I use your RSOP.msc method, I have to elevate to local admin account. Am I able to capture the user account?

Sorry, I'm not use to this level of troubleshooting. It's beyond what I've done. But I'm willing to give it a try.
peterliongAuthor Commented:
Rob,  the team that do the pushdown of the script finally decided to remove the script. So the error stop as well. Thank you for the help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RobSampsonCommented:
OK, cool. Sometimes you find that legacy things aren't needed any more, or there is a different way of doing things, so that's fine.  I'll go ahead and accept your closing comment for you.

Rob.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.