SharePoint 2013 Outgoing Email

I currently look after an SharePoint 2013 Server running in an SBS 2011 network with local Exchange. We had the internet service changed over from ADSL to NBN (fibre) link.
I have issue sending emails out of SharePoint. I created a virtual SMTP service which worked in the past with no issues.
Since the change over I can no longer send emails to any sender of my domain but seem to have no issues sending emails to outside recipients. Looking at the event log I get a warning smtpsvc event id 4000 "Message delivery to the remote domain 'mydomain.com.au' failed for the following reason: Unable to bind to the destination server in DNS. "
I have been using a smarthost to send emails out of the virtual smtp service.
I'm not sure what they are looking for? I would have expected the smarthost to route the email rather than the local DNS server.
I also tried to create an receive connector in exchange for SharePoint. Even if it is set to anonymous is still rejects with authentication error. Any help is very much appreciated
co_olAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jason CrawfordTransport NinjaCommented:
Are you using Exchange or IIS to relay email?
0
co_olAuthor Commented:
IIS to relay to a Smarthost,
I tried to route to exchange, but did not get to successfully connect to exchange. I have setup the Receive Connector in exchange correctly, as "anonymous users"  but when testing with Telnet it keeps getting rejected with authentication error. Makes no sense to me.
At least using IIS the external recipient get the email out of Sharepoint but not the internal recipients.
0
Jason CrawfordTransport NinjaCommented:
I apologize for the delay in my response, I've been out of town.

Here's a good guide to verify the IIS SMTP configuration:

http://blog.powerbiz.net.au/exchange/how-to-set-up-an-internal-smtp-service-for-windows-server-2012-essentials/

Ultimately I think your best bet is to relay through Exchange:

1. Enable verbose logging on all send and receive connectors
2. Create a new receive connector and call name is something unique to the type of email you'll be relaying
3. Specify the LAN IP of the application server in the 'Remote IP Ranges' field
4. Check the TLS box under the Authentication tab
5. Check the Anonymous box in the Permissions Group tab

That should be it if you're only relaying to internal addresses.  If you ever want to send to external, run this command:

Get-ReceiveConnector <Connector Name> | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

Open in new window

If troubleshooting is required, check the SMTPReceive logs here:

%ExchangeInstallPath%TransportRoles\Logs\Hub\ProtocolLog\SmtpReceive
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.