application response time - spinning cursor for 15-20 seconds

We support a veterinary practice running cornerstone and EMR system from Idexx.  there are several 'spots' in the application: looking up a note, processing an RX/prescription, getting a signature upload where the system response time is unacceptable.  Users can wait 15-20 seconds for the spinning cursor to respond.  we have contacted Idexx, the vendor, but have not yet received an explanation or a solution.

this looks to me like a server side response issue - but I am not sure - and would like to know if there is some way to show what the windows cursor is waiting for?

all of these issues seem to be file related in some way to me.

We have turned off Symantec and Malwarebytes with minimal improvement.

is there any way to see what windows is trying to do / waiting for?
LVL 1
bensonwalkerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nadav SolomonCommented:
Use Process Monitor to see exactly what is going on behind the scene.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pgm554Commented:
Without knowing the hardware ,OS, patch levels and network infrastructure ,it's almost impossible to give you a correct answer.

My first guess would be file server resources (ram,disk speed,processor power).

From there ,it would be OS and the SQL DB configuration.

And even though you turned off the AV,it just being loaded can cause problems.
0
Nadav SolomonCommented:
Glad I could help, thanks for the feedback.
0
bensonwalkerAuthor Commented:
this turned out to be a setting on a SOnicwall firewall.  we had to force the connection speed on the interface port vs letting it auto-configure......weird but true.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.