Server 2012 RDS Folder redirection not working

I have a Server 2012R2 Domain controller running the essentials role which installed the Group policy to redirect users and folders to a share on that server.  I have a server also running Server 2012 which has RDS installed.  That server is also the Connection broker, gateway and provides web access.  Licensing is on the Domain Controller and the SQL database is on a third server.

When a user logs onto the RD Host their folders are not redirected.  I have used group policy  modeling and that reports they should be applied and I have also confirmed that the policy is working correctly between workstations on the network,  it is only the RD host that it fails on.

I am sure this must be  a group policy issue but I cant see where
davidchristyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yo_beeDirector of Information TechnologyCommented:
Did you setup the Share with the proper Permissions and Security at the Parent Folder?
https://msdn.microsoft.com/en-us/library/cc736916(v=ws.10).aspx

\\Server1\RDF\
Have you looked at the event log on the server to see if there is an issue with GPO.

Applications and Services Logs -> Microsoft->Windows->GroupPolicy->Operational
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
The Event Log should detail why the policy is not applying.

If the base permissions were not configured correctly, though Essentials does this by wizard doesn't it?, then the resultant subfolders may be messed up. Verify the user's permissions for their folder as per the above link.

We also turn on Access-based Enumeration for that folder and the main company folder share.
0
davidchristyAuthor Commented:
I think I have worked out the problem,  but I have not worked out how to fix it.  The standard group policy generated by essentials is applied to the domain OU and has a WMI filter with it that excludes Server 2012 (select "from Win32 OperatingSystem where (Version) >= "6.1%) and ProductType = "1")

I need therefore to allow this policy work on the RDC server.  I created a new OU and put the server into it, then created a copy of the policy but without the WMI filter and then applied it to the new OU.  This did not work and I am a little lost as to how I now achieve this.  I am reluctant to simply remove the WMI policy as I still have some XP computers in the domain which will probably go berserk if I apply the policy to them.

What should I have done?
0
Rakesh KapoorCommented:
Step by step guide to configure Folder Redirection. Hope this would help you.

http://www.itingredients.com/how-to-configure-folder-redirection-gpo-in-server-2012/
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Remove the WMI filter from the SCOPE tab in GPMC for that GPO. That will make the GPO universal which is what it should be anyway.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.