No Datastores Recognized in ESXI 5.5

Good Morning,

I'm currently running version ESXI 5.5.0, 2403361 on a new Dell PowerEdge R430. I have 2 mirrored SD cards in which the ESXI is installed on. I then have 4 physical disks which are of 600 GB capacity each setup with a RAID 5 on a Dell RAID PERC H330 mini (embedded) controller. I ran a full initialization in which is completed successfully. When i log into VSphere and try to setup a new virtual machine, it doesn't show anything to configure the datastore. The status of the RAID and disks are showing good in the Web interface.

In Vsphere:
I go to "Create New Virtual Machine"
Custom
Fill in the box for the server name

Under "Select a designation for the virtual machine files" it shows an empty box. I have cleared the Raid configuration and reconfigured it to always just getting this same result.

Not sure why its not finding any datastore or storage devices for me to install the virtual machines on.

Thank you for your help!
transystemsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

amanytxCommented:
Are you using the partitions as shipped by Dell? In other words VM Ware does not let you format or add a data store unless you delete all partitions from the RAID controller utility. IF ESXi detects a utility partion or any other partion like NTFS for security of your data it will not let you add.

Recommend is to reboot server, log into RAID controller utility. reinitialize array and delete any partitions. restart host and once you log into ESXI client it will let you add and format array.

Good luck.
transystemsAuthor Commented:
The 4 physical disks came unpartitioned. I'll give this a try and will update with the results. Thank you
amanytxCommented:
Dell as of late on the servers we have ordered even though we order with no OS they still seem to load a small NTFS partition. We had this same issue about a year ago and spent half a day figuring out. Same version of esxi as you are using.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

transystemsAuthor Commented:
Looks like i'm still getting the same result. I remember when i was installing the ESXI, the only hardware that showed up were the SD cards. It didn't recognize anything else. Is there a way to update the RAID card since ESXI is the only thing installed?
amanytxCommented:
Ahhh This is why its not showing because its already partitioned for esxi. why don't you load the esxi host software on a internal USB drive and boot off of that. All our deployments are setup as that we have OS (esxi 5.5) installed on an internal usb which we make bootable in BIOS and then we leave array just for storage (datastores)
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Can you see the storage controller ?

make sure you are using the OEM DELL ESXi version from Dell.

Is your server and storage controller on the HCL ?
cooleditCommented:
hi there

from ssh
esxcli storage core adapter list (give us the output if you like)

if you see the LSI controller listed it might be that one that is use "Native Esxi driver)

esxcli software vib list (Again you can give us the output if you like)

if that is the case on some of these images it is the LSI driver that is running the storage module
if you do want to use the Mega driver from Dell if it is listed it requires a reboot.
As you can see in my picture the lsi_mr3 has loaded the module.

so to use the Mega controller Driver from Dell you need to disable the Lsi:
Disable the "lsi_mr3" driver by executing the following command: esxcli system module set --enabled=false --module=lsi_mr3 (works like a charm)

Cooledit
esxcli_Storage_core.jpg
cooleditCommented:
hi again

additonally you could
ssh:
Run the: esxcli storage core path list (give us the output).

Cooledit
transystemsAuthor Commented:
Good Morning,

Thank you everyone for your responses. It looked like once we upgraded to update 2 and ran the update manager, it finished patching all the updates, which now contained the RAID controller. The datastore is now recognized in vSphere and was successfully able to create a datastore. Thank you again for all your help!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
transystemsAuthor Commented:
Ran Update 2 and installed the latest patches. I did reformat the RAID again and then installed patches which found the RAID controller and was able to then create a datastore in vSphere.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.