Exchange 2013 Certs...status will not change

Hi everyone,

Ok, I'll try and be brief. Exchange 2013, created a new certificate request and received certificate. Attempting to "Complete" the certificate request doesn't work.

I can see the certs being installed in the MMC. I've tried to remove them and try again. I've also reset the IIS. It appears that when the certificate gets installed, the window should open to allow you to choose what services are assigned to that cert. However, the window simply closes and the status doesn't change.
Erick WAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin YeungSenior Systems EngineerCommented:
do get-exchangecertificate and see if the cert on the cas or cas/mailbox server

if you do Enable-ExchangeCertificate –Thumbprint {the code} -services “IIS, SMTP, POP, IMAP” –Server yourserver
0
Erick WAuthor Commented:
I realize now the question was too brief and I needed to provide a lot more information. Not a good question.

However, here is what I learned in resolving the situation myself. When I did a get-ExchangeCertificate on the CAS/MB server, the certificate was there. However, I couldn't assign any services.

The reason? I failed to notice a small "key" icon on the installed certificate. I believe this means the private key pair is either missing or corrupted. I ran "certutil -storerepair" on the certificate and the small "key" icon appeared on the certificate. After the icon appeared, I still was not able to enable the cert through the ECP. However, I was able to do it through powershell and the services attached fine.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Erick WAuthor Commented:
I accepted my own because it was more detailed than the original expert solution. However, this was due to the nature of the question.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.