Cant Unmount datastore on Vcenter 5.5

I have removed all VM's from this datastore and am trying to prep it to be deleted from the SAN.

Its best practice to unmount first before deleting it according to VMware.

But i am unable to.    I get the following error:

DataStore Unmount Error
I have tried Vsphere'ing directly to the Host and trying to Unmount with the same result.

I have not yet tried CLI.  But i first wanted to see if anyone on here may have run into the same issue before and know how to resolve it.

I have also tried to remove the entry from the Hosts local files.

help
JB BlancoSr Systems EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

amanytxCommented:
Have you checked to make sure you dont have any orphaned files especially esxi host log files or folders?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
there is a checker, which checks the datastore is not in use before it is unmounted.

browse the datastore, any files left ?
0
cooleditCommented:
hi Jblanc

try follow this article from VMware and tell us if you still have problems:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2004605

Regards
Cooledit
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

JB BlancoSr Systems EngineerAuthor Commented:
There are no files left.

Browsing the datastore show just 2 folders but they are empty.

.sdd.sf  and .VSphere-HA
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
the datastore is in use by vSphere HA as a VMware HA Heartbeat datastore.

change the HA settings, to exclude this datastore for VMware vSphere HA, in Cluster Settings.
0
compdigit44Commented:
Also make sure Storage I/O control for the datastore is disabled
0
JB BlancoSr Systems EngineerAuthor Commented:
These Datastores in question are not checked in Vsphere HA.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
well there is a .VSphere-HA on the datastore, it would not be there, if it was not in use.

does it let you delete it ?
0
JB BlancoSr Systems EngineerAuthor Commented:
hi everyone,

I left this question un-resolved because I had other things to deal with.,


I will get back to this question later
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
ok...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JB BlancoSr Systems EngineerAuthor Commented:
ok i no-longer work at this location where this problem was happening.  

I cant possibly continue troubleshooting this issue because its no longer present.

how the heck do i just delete this question so i can ask another!???
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.