New install of SQL 2008 has no SQL services

Did an install of SQL 2008 SP2 and then Management Tools.  when I tried to login to the database it failed.  I then checked the services and there are zero SQL services.

How can that be?

How do I fix it?
J.R. SitmanIT DirectorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas GrassiSystems AdministratorCommented:
Have you restarted the server after the install?

Give that a try first

HTH
0
Dave BaldwinFixer of ProblemsCommented:
How did you try to login?  Did you reboot to start the services?  In SQL Configuration Manager, what protocols do you have enabled?
0
J.R. SitmanIT DirectorAuthor Commented:
Tried logging in as (local), SQLSERVER and (local)\SQLSERVER.  Note SQLSERVER is actually the name of the server.
I have Shared memory, tcp/ip and named pipes enabled
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Dave BaldwinFixer of ProblemsCommented:
But what method or program are you using?  SSMS will normally show the local/default instance with a Windows Auth login showing your user.  ??
0
J.R. SitmanIT DirectorAuthor Commented:
Rebooted it earlier and again just now.  Still no services.  If I look in Programs and Features SQL is there.
0
J.R. SitmanIT DirectorAuthor Commented:
See attached
sql2.jpg
0
Dave BaldwinFixer of ProblemsCommented:
Hmm.... if you're not seeing it in Task Manager under 'sqlserver.exe' and/or 'sqlbrowser.exe' then it's basically not running.  See if you have a program called something like SQL Server Surface Area Configuration.  There are a lot of things that can be set up using it.
0
Thomas GrassiSystems AdministratorCommented:
How are you looking for the services?

Go to powershell run this get-service

Post results
0
Dave BaldwinFixer of ProblemsCommented:
Click on the Server Name dropdown and see if there is another server name there.  (local) is not what I'm used to seeing.
0
J.R. SitmanIT DirectorAuthor Commented:
There is (local) \SQLEXPRESS, which was previously installed on this server.  However, one of the programs I;m using (according to their support) requires the full version of SQL.  So I uninstalled all SQL and started over.

I ran the PS,,but how do I post the results?
0
Thomas GrassiSystems AdministratorCommented:
Get-service >>c:\service.txt
0
J.R. SitmanIT DirectorAuthor Commented:
attached
service.txt
0
Thomas GrassiSystems AdministratorCommented:
Ok you need to uninstall sql express first
Do a system restart
Then install sql 2008

HTH
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
J.R. SitmanIT DirectorAuthor Commented:
I did a complete uninstall of all SQL previously.  I'll do it again, but how do I insure SQLExpress gets uninstalled?
0
Thomas GrassiSystems AdministratorCommented:
0
J.R. SitmanIT DirectorAuthor Commented:
2005 isn't there.  I just ran get-service after uninstalling SQL and there is no SQL service.  I'm rebooting.  Leaving office soon.  Will post tonight or tomorrow.
0
arnoldCommented:
Many things make no sense.

It looks as though you uninstalled the wrong instance.

Installing an update does not remove installed apps.

Having no prior reference to what you had, it is impossible to guess in what might have happened.
Search for .mdb files and hopefully you have backups.

Are you sure you are on the right system where the database services you though you were updating were actually installed?
0
J.R. SitmanIT DirectorAuthor Commented:
Sorry for not posting.  I had to do a complete uninstall and full install again.  It's working.
0
J.R. SitmanIT DirectorAuthor Commented:
After doing this a second time it worked.

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.