How can I get proper MB/s using iperf

Why are the results not showing MB/s in some normal way? For example 30MB/s or 48MB/s.

# iperf -d -c 1.1.1.1 -fMB
------------------------------------------------------------
Client connecting to 1.1.1.1, TCP port 5201
TCP window size: 0.02 MByte (default)
------------------------------------------------------------
[  3] local 192.168.1.58 port 50373 connected with 1.1.1.1 port 5201
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  17592186044415 MBytes  1757330879611 MBytes/sec
projectsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetExpert Network Solutions Pte LtdTechnical SpecialistCommented:
I am not sure, how you run iperf. the below url will help you to run the iperf methods and calculate the bandwidth

http://openmaniak.com/iperf.php
0
projectsAuthor Commented:
That's the point, I don't want to do calculations, I'd like the program to give me the output that so many examples on the net show, but it doesn't.

Even a tiny bash script would be great, showing time, speed and bandwidth.
0
Dan CraciunIT ConsultantCommented:
You have an extra B:

iperf -c 1.1.1.1 -f M

HTH,
Dan
0
Become a Leader in Data Analytics

Gain the power to turn raw data into better business decisions and outcomes in your industry. Transform your career future by earning your MS in Data Analytics. WGU’s MSDA program curriculum features IT certifications from Oracle and SAS.  

projectsAuthor Commented:
Same result without the B, using only -fM
0
Dan CraciunIT ConsultantCommented:
I always use f space M
0
projectsAuthor Commented:
Same results, I've tried all those combinations which is why I ended up posting this question.
This probably needs a bash script to make it work.
0
gheistCommented:
Your client system has some timing problems. (or you have 20 petabit network cards not yet invented?)
0
projectsAuthor Commented:
Ack, I gave away the secret! :).

Anyhow, I tried this on a centos7 machine and that works fine, without any options no less.
Have to test some other clients.
0
gheistCommented:
:) if it is windows you can try forcing it into permanent high performance mode, maybe timer is right then.
0
projectsAuthor Commented:
It's all Linux.
0
gheistCommented:
change clocksource to something better than tsc
0
projectsAuthor Commented:
Like I said, it works from centos7 and windows clients. If I recall, the client I was originally testing from was a Ubuntu machine.

Not sure but it's all working now.
0
gheistCommented:
check dmesg - if it invalidates tsc just add clocksource=acpi_pm to have very stable high-res timer.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gheistCommented:
... to boot command line (/etc/sysconfig/grub /etc/grub.conf) ONLY on systems that are unable to invalidate unstable TSC.... (btw debian works for me good, but RHEL and fedora coughs, maybe you are in other side of globe and it is other way around)...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Analysis

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.